<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>Look out! Divergent representations are everywhere! | Trail of Bits Blog</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://blog.trailofbits.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://blog.trailofbits.com/wp-content/themes/everyday/js/html5.js" type="text/javascript"></script>
<![endif]-->

<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="Lbyyor8qrpJf-6qi1ql45JDKAmXUIcc3N0mFeVNwUok" />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Trail of Bits Blog &raquo; Feed" href="https://blog.trailofbits.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Trail of Bits Blog &raquo; Comments Feed" href="https://blog.trailofbits.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Trail of Bits Blog &raquo; Look out! Divergent representations are everywhere! Comments Feed" href="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.trailofbits.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(p&&p.fillText)switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-12282b262e336aff3912bb8e691cf970' href='https://blog.trailofbits.com/_static/??-eJyFUltuAjEMvFCDqdrS/lT9QeIAPUCVTaxgcB6KE7Z7+2ZZqIBC+cskM/aMnT4pE0PBUCBxdRQEXG2ww+ygq8QWOo5mq5i6rPMAUgbGmRF56P9KWQ+xFuUy2XMiBcPVosBGwKMljYx+VJ6C1OSYFaPTZph5CnfV7e0UX9U0DIa1CBlV1o0np7RjAl/VMUSfTPSyhh0GGzPoWqLXpZCBgt9laqh6sg6L2oecehxuRs6t8VxOtvVJMTSG/D9WE/c7EPgNtcTU3GEw1MAqLrW1A3xOZqbarAvKTScbLEmbLfho66hh2uINE9PMAHeYB6vvfIDLurLWGe3e3Xik4O4pv1pGkGhIs+LoopyBa6u7rDAu43AeqR/+/XGxeH1+e5k/zX8AsX8fjg==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='dashicons-css' href='https://blog.trailofbits.com/wp-includes/css/dashicons.min.css?ver=6.1' media='all' />
<link rel='stylesheet' id='everyday-droid-serif-css' href='https://fonts.googleapis.com/css?family=Droid+Serif%3A400%2C700%2C400italic%2C700italic&#038;ver=20120328' media='all' />
<link rel='stylesheet' id='everyday-droid-sans-css' href='https://fonts.googleapis.com/css?family=Droid+Sans%3A400%2C700&#038;ver=20120328' media='all' />
<link rel='stylesheet' id='everyday-droid-mono-css' href='https://fonts.googleapis.com/css?family=Droid+Sans+Mono&#038;ver=20120328' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<script id='media-video-jwt-bridge-js-extra'>
var videopressAjax = {"ajaxUrl":"https:\/\/blog.trailofbits.com\/wp-admin\/admin-ajax.php","bridgeUrl":"https:\/\/blog.trailofbits.com\/wp-content\/plugins\/jetpack\/jetpack_vendor\/automattic\/jetpack-videopress\/src\/..\/build\/lib\/videopress-token-bridge.js","post_id":"103122"};
</script>
<script src='https://blog.trailofbits.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-videopress/src/../build/lib/videopress-token-bridge.js?ver=0.6.5' id='media-video-jwt-bridge-js'></script>
<script src='https://blog.trailofbits.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.1' id='jquery-core-js'></script>
<script type='text/javascript'  src='https://blog.trailofbits.com/wp-includes/js/jquery/jquery-migrate.min.js?m=1605690366'></script>
<link rel="https://api.w.org/" href="https://blog.trailofbits.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.trailofbits.com/wp-json/wp/v2/posts/103122" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.trailofbits.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.trailofbits.com/wp-includes/wlwmanifest.xml" />

<link rel="canonical" href="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/" />
<link rel='shortlink' href='https://blog.trailofbits.com/?p=103122' />
<link rel="alternate" type="application/json+oembed" href="https://blog.trailofbits.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.trailofbits.com%2F2022%2F11%2F10%2Fdivergent-representations-variable-overflows-c-compiler%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.trailofbits.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.trailofbits.com%2F2022%2F11%2F10%2Fdivergent-representations-variable-overflows-c-compiler%2F&#038;format=xml" />
	<style>img#wpstats{display:none}</style>
		<style>
#page {
	background-color: #f7f7f7;
}
</style>

<meta name="description" content="By Andreas Kellas Trail of Bits recently published a blog post about a signed integer overflow in certain versions of SQLite that can enable arbitrary code execution and result in a denial of service. While working on proof-of-concept exploits for that vulnerability, we noticed that the compiler’s representation of an important integer variable is semantically&hellip;" />
<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("https://blog.trailofbits.com/wp-content/themes/everyday/images/background.png"); background-position: left top; background-size: auto; background-repeat: repeat; background-attachment: scroll; }
</style>
				<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Look out! Divergent representations are everywhere!" />
<meta property="og:url" content="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/" />
<meta property="og:description" content="By Andreas Kellas Trail of Bits recently published a blog post about a signed integer overflow in certain versions of SQLite that can enable arbitrary code execution and result in a denial of servi…" />
<meta property="article:published_time" content="2022-11-10T12:30:53+00:00" />
<meta property="article:modified_time" content="2022-11-10T14:06:08+00:00" />
<meta property="og:site_name" content="Trail of Bits Blog" />
<meta property="og:image" content="https://blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM-1024x986.png" />
<meta property="og:image:width" content="690" />
<meta property="og:image:height" content="664" />
<meta property="og:image:alt" content="" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@trailofbits" />
<meta name="twitter:site" content="@trailofbits" />
<meta name="twitter:text:title" content="Look out! Divergent representations are everywhere!" />
<meta name="twitter:image" content="https://blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM-1024x986.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2020/07/cropped-android-chrome-512x512-1.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2020/07/cropped-android-chrome-512x512-1.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2020/07/cropped-android-chrome-512x512-1.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2020/07/cropped-android-chrome-512x512-1.png?fit=270%2C270&#038;ssl=1" />
<style type="text/css" id="wp-custom-css">/*
Welcome to Custom CSS!

To learn how this works, see http://wp.me/PEmnE-Bt
*/
.entry-content {
	padding-left: 0;
}

.entry-content
blockquote {
	margin-left: 25px;
}

.entry-content
.embed {
	margin-left: 0;
}

.entry-content
.embed-youtube {
	margin-left: 0;
}

/* To remove the infinite scroll footer HC-23308875-SK */
#infinite-footer
{
  display:none;
}

.wp-caption 
.wp-caption-text {
	text-align: center;
}</style><!-- Your Google Analytics Plugin is missing the tracking ID -->
</head>

<body class="post-template-default single single-post postid-103122 single-format-standard custom-background group-blog">
<div id="page" class="hfeed site">
		<header id="masthead" class="site-header" role="banner">
		<hgroup>
			<h1 class="site-title"><a href="https://blog.trailofbits.com/" title="Trail of Bits Blog" rel="home">Trail of Bits Blog</a></h1>
			<h2 class="site-description"></h2>
					</hgroup>

		<nav role="navigation" class="site-navigation main-navigation">
			<h1 class="assistive-text">Menu</h1>
			<div class="assistive-text skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>
			<div class="menu"><ul>
<li ><a href="https://blog.trailofbits.com/">Home</a></li></ul></div>
		</nav>
	</header><!-- #masthead .site-header -->

	<div id="main" class="main">
		<div id="primary" class="site-content">
			<div id="content" role="main">

			
				
<article id="post-103122" class="post-103122 post type-post status-publish format-standard hentry category-binary-ninja category-codeql category-internship-projects category-research-practice category-uncategorized entry">
	<header class="entry-header">

		<h1 class="entry-title">Look out! Divergent representations are everywhere!</h1>
					<ul class="entry-meta">
				<li class="entry-format">Post</li>
				<li class="permalink"><a href="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/" title="7:30 am" rel="bookmark"><time class="entry-date" datetime="2022-11-10T07:30:53-05:00" pubdate>November 10, 2022</time></a></li>
				<li class="comment-link"><a href="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/#respond">Leave a comment</a></li>
							</ul><!-- .entry-meta -->
			</header><!-- .entry-header -->

	<div class="entry-content">
		<p><strong>By Andreas Kellas</strong></p>
<p>Trail of Bits recently published a <a href="https://blog.trailofbits.com/2022/10/25/sqlite-vulnerability-july-2022-library-api/" target="_blank" rel="noopener">blog post</a> about a signed integer overflow in certain versions of SQLite that can enable arbitrary code execution and result in a denial of service. While working on proof-of-concept exploits for that vulnerability, we noticed that the compiler’s representation of an important integer variable is semantically different in different parts of the program. These differences result in inconsistent interpretations of the variable when it overflows, which we call “divergent representations.” Once we found an example, we tried to find more—and discovered that divergent representations are actually quite common in compiled C code.</p>
<p>This blog post examines divergent representations of the same source code variable produced by compiler optimizations. We’ll attempt to define divergent representations and look at the SQLite vulnerability we discovered, which was made <em>easier to exploit</em> by the divergent representation of a source code variable (one exhibiting undefined behavior). We’ll then describe the binary and source code analyses that we used to find more divergent representations in existing open-source codebases. Finally, we’ll share some suggestions for eliminating the risk that a program will be compiled with divergent representations.</p>
<h2>A simple example</h2>
<p>Here&#8217;s a simple example of a real-life code pattern that can result in divergent representations:</p>
<pre>int index_of(char *buf, char target) {
    int i;
    for (i=0; buf[i] != target; i++) {}
    return i;
}
</pre>
<p>The <code>index_of</code> function receives a character array as input, loops through the array and increments <code>i</code> until it encounters the first target character, and returns the index of that target character. One might expect that <code>buf[index_of(buf, target)] == target</code>, but the evaluation of that statement can depend on the compiler’s optimization level. More specifically, it can depend on the compiler’s handling of undefined behavior when the value of <code>i</code> exceeds the maximum positive <code>int</code> value (<code>INT_MAX</code>, i.e., <code>0x7fffffff</code>).</p>
<p>If the target character appears in the first <code>INT_MAX</code> bytes of the buffer, the function will exhibit well-defined behavior, assuming that the platform uses 32-bit integers. If the function scans the first <code>INT_MAX</code> bytes of the array without finding the target character, <code>i</code> will be incremented beyond the maximum representable positive value for the <code>int</code> type, which is undefined behavior.</p>
<p>So how would the compiler handle that code—that is, code that could exhibit a signed integer overflow at runtime? Of course, because signed integer overflows are undefined behavior, the compiler could choose to do anything at all, including producing “<a href="http://www.catb.org/jargon/html/N/nasal-demons.html" target="_blank" rel="noopener">nasal demons</a>.” This is a question about expectations, then: What would we expect a reasonable compiler to do? If <code>i</code> were incremented beyond <code>INT_MAX</code>, where would we expect <code>index_of</code> to try to read a character from memory?</p>
<p>We might expect the compiler to make one of two seemingly reasonable choices:</p>
<ol>
<li>Represent <code>i</code> as a signed 32-bit value, causing <code>i</code> to wrap from <code>INT_MAX</code> (a positive value represented as <code>0x7fffffff</code>) to <code>INT_MIN</code> (a negative value represented as <code>0x80000000</code>), in which case the function would read the next byte from buf[INT_MIN] as a negative array index</li>
<li>Represent <code>i</code> as an unsigned 64-bit value, causing <code>i</code> to increment to the unsigned value <code>0x80000000</code> and the function to read the next byte from <code>buf[0x80000000ul]</code>, which is the next contiguous byte in memory</li>
</ol>
<p>In either case, if the next character read were the target byte, the <code>index_of</code> function would return <code>(int) 0x80000000</code>, which is <code>INT_MIN</code> (a negative number). However, in case 2, the memory location checked for the target character would not be <code>buf[INT_MIN]</code>. In other words, the expression <code>buf[index_of(buf, target)] == target</code> would not be true if the compiler chose to represent <code>i</code> as an unsigned 64-bit value—and that is exactly how <a href="https://godbolt.org/z/rzMdEGb66" target="_blank" rel="noopener">Clang compiles <code>index_of</code></a> at optimization level -O1 and above:</p>
<pre class="brush: plain; gutter: false; title: ; notranslate" title="">
index_of(char*, char):              # @index_of(char*, char)
        mov     eax, -1
.LBB0_1:                            # =&gt;This Inner Loop Header: Depth=1
        inc     eax
        lea     rcx, [rdi + 1]
        cmp     byte ptr [rdi], sil
        mov     rdi, rcx
        jne     .LBB0_1
        ret

</pre>
<p>This is an example of a divergent representation of the same source code variable, <code>i</code>. The value of <code>i</code> returned by the function is represented by addition (<code>inc</code>) on the 32-bit <code>eax</code> register, while the value of <code>i</code> used to access the array buffer is represented by addition (<code>lea</code>) on the 64-bit <code>rdi</code> register. The source code makes no distinction between these two versions of <code>i</code>, as the programmer likely expected that the value used to index into the buffer would be the same one returned by the function. As we’ve shown, though, that is not the case.</p>
<h2>How do divergent representations appear?</h2>
<p>A compiler can apply optimizations to a program to improve the program’s performance. Compilers must ensure the correctness of operations over well-defined inputs, but they can take arbitrary liberties to speed up the execution of undefined behavior. For example, to optimize code on a 64-bit platform, a compiler can replace 32-bit addition with 64-bit addition, because the defined behavior of addition on a 32-bit platform is also defined behavior on a 64-bit platform.</p>
<p>A divergent representation occurs when a compiler applies program optimizations that cause a single source variable to be represented with different semantics in the output program. The instances of divergent representations that we’ve observed all result from undefined behavior (particularly signed integer overflows). Since programmers shouldn’t write programs with undefined behavior, one could argue that divergent representations are a non-issue. However, we assert that programs ought to have consistent interpretations of the same value even in cases of undefined behavior.</p>
<p>The divergent representations that we’ve found occur in code that fits the following pattern:</p>
<ol>
<li>A signed integer variable is declared outside of a loop.</li>
<li>The variable is incremented or decremented in the loop and is allowed to overflow.</li>
<li>The variable is used in the loop to access an array.</li>
<li>The variable is used outside of the loop.</li>
</ol>
<p>A 2011 discussion <a href="https://groups.google.com/g/llvm-dev/c/sDYaYV_ZF-g/m/5Ektu6vM_0oJ" target="_blank" rel="noopener">on the LLVM developers mailing list</a> provides fascinating insight into the representation of variables that may overflow, along with the effect that an overflow has on optimizations.</p>
<h2>A wild divergent representation appears!</h2>
<p>We discovered our first divergent representation while we were trying to develop a proof-of-concept exploit for <a href="https://github.com/trailofbits/publications/tree/master/disclosures/CVE-2022-35737#readme" target="_blank" rel="noopener">CVE-2022-35737</a>, a vulnerability that we discovered in SQLite. We noticed that our proof-of-concept exploit behaved differently when executed with a debug build of <code>libsqlite3.so</code> (compiled without optimizations) and with the optimized release version of <code>libsqlite3.so</code>; we found that curious, as it seemed to imply that the optimizations had produced semantically different compilations of the same library.</p>
<p>We dug deeper by disassembling the two versions of the library and analyzing the code near the vulnerability. The differences in the compiled code stem from the source code, specifically the <a href="https://sqlite.org/src/info?name=6166a30417b05c5b2f82e1f183f75faa2926ad60531c0b688a57dbc951441a20&amp;ln=824-830" target="_blank" rel="noopener"><code>sqlite3_str_vappendf</code></a> function:</p>
<pre>806 int i, j, k, n, isnull;
    ...
824 k = precision;
825 for(i=n=0; k!=0 &amp;&amp; (ch=escarg[i])!=0; i++, k--){
826   if( ch==q )  n++;
827   if( flag_altform2 &amp;&amp; (ch&amp;0xc0)==0xc0 ){
828     while( (escarg[i+1]&amp;0xc0)==0x80 ){ i++; }
829   }
830 }
</pre>
<p>The figure below shows the disassembled version of the optimized binary:</p>
<p><a href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?ssl=1"><img data-attachment-id="103154" data-permalink="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/screenshot-2022-11-04-at-2-34-25-pm/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?fit=1232%2C1186&amp;ssl=1" data-orig-size="1232,1186" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screenshot 2022-11-04 at 2.34.25 PM" data-image-description data-image-caption data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?fit=300%2C289&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?fit=690%2C664&amp;ssl=1" decoding="async" class="aligncenter size-large wp-image-103154 jetpack-lazy-image" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?resize=690%2C664&#038;ssl=1" alt width="690" height="664" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?resize=1024%2C986&amp;ssl=1 1024w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?resize=300%2C289&amp;ssl=1 300w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?resize=768%2C739&amp;ssl=1 768w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?resize=1200%2C1155&amp;ssl=1 1200w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?w=1232&amp;ssl=1 1232w" data-lazy-sizes="(max-width: 690px) 100vw, 690px" data-lazy-src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?resize=690%2C664&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="103154" data-permalink="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/screenshot-2022-11-04-at-2-34-25-pm/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?fit=1232%2C1186&amp;ssl=1" data-orig-size="1232,1186" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screenshot 2022-11-04 at 2.34.25 PM" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?fit=300%2C289&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?fit=690%2C664&amp;ssl=1" decoding="async" class="aligncenter size-large wp-image-103154" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?resize=690%2C664&#038;ssl=1" alt="" width="690" height="664" srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?resize=1024%2C986&amp;ssl=1 1024w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?resize=300%2C289&amp;ssl=1 300w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?resize=768%2C739&amp;ssl=1 768w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?resize=1200%2C1155&amp;ssl=1 1200w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.34.25-PM.png?w=1232&amp;ssl=1 1232w" sizes="(max-width: 690px) 100vw, 690px" data-recalc-dims="1"  /></noscript></a></p>
<p>In that code snippet, a user input buffer (<code>escarg</code>) is scanned for quotation marks and Unicode characters. At instruction [1a], <code>r10</code> contains the address of <code>escarg</code>, and <code>rsi</code> is used to index into the buffer to fetch a value from it; the <code>rsi</code> register is set in the previous instruction, which sign-extends the 32-bit <code>edx</code> register. This indexing operation corresponds to the <code>escarg[i]</code> expression on line 825 of the source code. With each loop iteration, <code>edx</code> is incremented at instruction [1b]; thus, the source code variable <code>i</code> is represented as a signed 32-bit integer and can be used as a negative index into <code>escarg</code>.</p>
<p>However, instruction [2a] shows something different: <code>r10</code> still contains the address of <code>escarg</code>, but <code>rax+1</code> is used to index into the buffer in the inner loop that scans for Unicode characters (in the <code>escarg[i+1]</code> expression on line 828 of the source code). Instruction [2b] increments <code>rax</code> as a 64-bit value—and with no 32-bit sign extension—before looping back to [2a]. This version of <code>i</code> is represented as a 64-bit unsigned integer, so when <code>i</code> exceeds the maximum 32-bit signed integer value (<code>0x7fffffff</code>), its next memory access will be at <code>escarg+0x80000000</code>.</p>
<p>The exploit worked by leveraging the different semantics for <code>i</code> on line 828; these semantics cause <code>i</code> to wrap to a specific small positive value upon an overflow, so it will not be used as a negative index into the <code>escarg</code> buffer on line 825. Details on the exploit are provided in our blog post <a href="https://blog.trailofbits.com/2022/10/25/sqlite-vulnerability-july-2022-library-api/" target="_blank" rel="noopener">about the vulnerability</a> and <a href="https://github.com/trailofbits/cve-2022-35737" target="_blank" rel="noopener">in our proof-of-concept exploits</a>.</p>
<h2>Searching for more divergent representations</h2>
<p>After finding a divergent representation in a popular codebase, we started wondering, “Is it a one-off? Can we find divergent representations in other projects?” We tried two approaches to identifying other potential divergent representations and found more examples in SQLite and <code>libxml2</code>.</p>
<h3>Bottom-up (compiled binary) search</h3>
<p>In our first attempt to find more divergent representations, we took a “bottom-up” approach, looking directly at compiled binaries. We wrote a <a href="https://github.com/trailofbits/divergent-representations/blob/main/binja-scripts/fdr.py" target="_blank" rel="noopener">Binary Ninja script</a> that models the compiled patterns of divergent representations and leverages the abstractions provided by Binary Ninja’s Medium Level Intermediate Language (MLIL) Static Single Assignment (SSA) form. We scanned all instructions in each function’s MLIL representation for any Phi nodes that do the following:</p>
<ol>
<li>Use a variable that is defined by the Phi node’s defined variable (indicating that the node may affect a loop-control variable)</li>
<li>Define a variable that is used in a downcasting operation (and is thus represented elsewhere as a narrower value)</li>
<li>Use a variable that is assigned multiple sizes (i.e., a variable that may be represented as either 64 bit or 32 bit)</li>
<li>Define a variable that is used in a subsequent 64-bit operation</li>
</ol>
<p>If a Phi node matched all of those criteria, we marked it as a potential source of a divergent representation and printed it to the Binary Ninja console terminal for investigation.</p>
<p>Our script found additional potential divergent representations in both SQLite and <code>libxml2</code>, including in the <code>libxml2</code> nodes below:</p>
<div id="attachment_103160" style="width: 645px" class="wp-caption aligncenter"><a href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/nodes.png?ssl=1"><img aria-describedby="caption-attachment-103160" data-attachment-id="103160" data-permalink="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/nodes/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/nodes.png?fit=635%2C155&amp;ssl=1" data-orig-size="635,155" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="nodes" data-image-description data-image-caption="&lt;p&gt;The first five Phi nodes identified by the Binary Ninja script in its scan of libxml2.so&lt;/p&gt;
" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/nodes.png?fit=300%2C73&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/nodes.png?fit=635%2C155&amp;ssl=1" decoding="async" class="size-full wp-image-103160 jetpack-lazy-image" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/nodes.png?resize=635%2C155&#038;ssl=1" alt width="635" height="155" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/nodes.png?w=635&amp;ssl=1 635w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/nodes.png?resize=300%2C73&amp;ssl=1 300w" data-lazy-sizes="(max-width: 635px) 100vw, 635px" data-lazy-src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/nodes.png?resize=635%2C155&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" aria-describedby="caption-attachment-103160" data-attachment-id="103160" data-permalink="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/nodes/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/nodes.png?fit=635%2C155&amp;ssl=1" data-orig-size="635,155" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="nodes" data-image-description="" data-image-caption="&lt;p&gt;The first five Phi nodes identified by the Binary Ninja script in its scan of libxml2.so&lt;/p&gt;
" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/nodes.png?fit=300%2C73&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/nodes.png?fit=635%2C155&amp;ssl=1" decoding="async" loading="lazy" class="size-full wp-image-103160" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/nodes.png?resize=635%2C155&#038;ssl=1" alt="" width="635" height="155" srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/nodes.png?w=635&amp;ssl=1 635w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/nodes.png?resize=300%2C73&amp;ssl=1 300w" sizes="(max-width: 635px) 100vw, 635px" data-recalc-dims="1"  /></noscript></a><p id="caption-attachment-103160" class="wp-caption-text">The first five Phi nodes identified by the Binary Ninja script in its scan of libxml2.so</p></div>
<p>The script also identified the following Phi node not pictured above:</p>
<pre>xmlBuildURI@0x7b6c0: rax_33#51 = ϕ(rax_33#50, rax_33#52)</pre>
<p>The <code>addr2line</code> utility indicates that this portion of the binary corresponds to <a href="https://github.com/GNOME/libxml2/blob/0aa8652e596a20e95ed334ac65cf15e6e9ec4b3b/uri.c#L2085" target="_blank" rel="noopener">libxml2/uri.c:2085</a> in the <code>xmlBuildURI</code> function:</p>
<pre>   2084 while (bas-&gt;path[cur] != 0) {
    2085     while ((bas-&gt;path[cur] != 0) &amp;&amp; (bas-&gt;path[cur] != '/'))
    2086         cur++;
    2087     if (bas-&gt;path[cur] == 0)
    2088           break;
    2089
    2090     cur++;
    2091     while (out &lt; cur) { 2092 res-&gt;path[out] = bas-&gt;path[out];
    2093           out++;
    2094     }
    2095 }
</pre>
<p>This code pattern appears to be similar to that in the original SQLite code. Note, though, that code compiled with divergent representations will not necessarily be reachable, even with undefined inputs. For example, if there is no way to advance the integer cur beyond the acceptable values for a 32-bit integer, the semantics of the integer in the above code snippet will not diverge.</p>
<p>Unsurprisingly, when we ran our script on a version of the libraries compiled without optimizations (level -O0), we did not find any divergent representations. That outcome validated our understanding of divergent representations as caused by compiler optimizations.</p>
<h3>Top-down (source code) search</h3>
<p>We also performed a “top-down” search for source code patterns that could produce divergent representations when compiled with optimizations.</p>
<p>We used <a href="https://codeql.github.com/" target="_blank" rel="noopener">CodeQL</a> to create <a href="https://github.com/trailofbits/divergent-representations/tree/main/codeql-queries" target="_blank" rel="noopener">source code queries</a>. These queries identify source code in which the following conditions hold:</p>
<ol>
<li>A variable is declared outside of a loop.</li>
<li>The variable is incremented in the loop body.</li>
<li>The variable is used to access memory in a statement in the loop body.</li>
<li>The variable is used again after the loop, outside of the loop body.</li>
</ol>
<p>We also ran CodeQL with an additional optional condition, querying for cases in which the variable is used to access memory in a conditional statement in the loop, rather than just in its body. That cut down on the number of false positives by eliminating cases in which a loop condition prevents the variable from overflowing. (For example, if i is used in the loop condition <code>i &lt; 10</code>, it won’t overflow, but if the loop condition is <code>buf[i] != x, i</code> may overflow.)</p>
<p>CodeQL found 20 code patterns that could produce divergent representations in <code>libxml2</code>, two of which (in <code>xmlBuildURI</code>) were also identified by Binary Ninja.</p>
<p><a href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?ssl=1"><img data-attachment-id="103166" data-permalink="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/screenshot-2022-11-04-at-2-57-58-pm/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?fit=1240%2C694&amp;ssl=1" data-orig-size="1240,694" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screenshot 2022-11-04 at 2.57.58 PM" data-image-description data-image-caption data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?fit=300%2C168&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?fit=690%2C386&amp;ssl=1" decoding="async" class="aligncenter size-large wp-image-103166 jetpack-lazy-image" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?resize=690%2C386&#038;ssl=1" alt width="690" height="386" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?resize=1024%2C573&amp;ssl=1 1024w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?resize=300%2C168&amp;ssl=1 300w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?resize=768%2C430&amp;ssl=1 768w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?resize=1200%2C672&amp;ssl=1 1200w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?w=1240&amp;ssl=1 1240w" data-lazy-sizes="(max-width: 690px) 100vw, 690px" data-lazy-src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?resize=690%2C386&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="103166" data-permalink="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/screenshot-2022-11-04-at-2-57-58-pm/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?fit=1240%2C694&amp;ssl=1" data-orig-size="1240,694" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screenshot 2022-11-04 at 2.57.58 PM" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?fit=300%2C168&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?fit=690%2C386&amp;ssl=1" decoding="async" loading="lazy" class="aligncenter size-large wp-image-103166" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?resize=690%2C386&#038;ssl=1" alt="" width="690" height="386" srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?resize=1024%2C573&amp;ssl=1 1024w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?resize=300%2C168&amp;ssl=1 300w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?resize=768%2C430&amp;ssl=1 768w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?resize=1200%2C672&amp;ssl=1 1200w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/11/Screenshot-2022-11-04-at-2.57.58-PM.png?w=1240&amp;ssl=1 1240w" sizes="(max-width: 690px) 100vw, 690px" data-recalc-dims="1"  /></noscript></a></p>
<p>Note that our top-down and bottom-up searches identified code in which divergent representations may exist; an actual divergence in the program semantics would still require input that caused undefined behavior.</p>
<h2>Preventing divergent representations in compiled programs</h2>
<p>The best way to prevent a divergent representation is to avoid including undefined behavior in a program. That’s not particularly actionable advice, though. It would be even less helpful for us to suggest that programmers avoid writing <code>for</code> and <code>while</code> loops that use variables declared outside of the loop.</p>
<p>Instead, programmers should use data types that cannot overflow for variables used to count or access arrays (e.g., <code>size_t</code> or <code>uintptr_t</code> instead of <code>int</code>). They should also avoid a practice that is unfortunately common among C programmers: tying error conditions to <code>int</code> functions’ negative return values (e.g., using a return value of <code>-1</code> to indicate a failure); assuming a larger-scale refactoring is not possible, we recommend using <code>ssize_t</code> instead of <code>int</code> in those cases. Finally, programmers should avoid making any assumptions whatsoever about what a program will do in response to undefined behavior.</p>
<h2>Conclusion</h2>
<p>We cannot make a blanket statement assessing the risks associated with divergent representations. Some, basically unreachable, can be seen as curiosities of undefined behavior—a source of C programming trivia questions that will stump your friends. Others may be more consequential, turning otherwise benign integer overflows into exploitable vulnerabilities, as in the case of our SQLite vulnerability. Our hope is that by describing the phenomena and enabling programmers to identify divergent representations when they appear, we can help the community accurately gauge their severity.</p>
<p>I’d like to thank my mentor, Peter Goodman, for his expert guidance in the pursuit of vulnerabilities and weird compiler behaviors during my summer internship with Trail of Bits.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-103122" class="share-twitter sd-button share-icon" href="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/?share=twitter" target="_blank" title="Click to share on Twitter" ><span>Twitter</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-103122" class="share-linkedin sd-button share-icon" href="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/?share=linkedin" target="_blank" title="Click to share on LinkedIn" ><span>LinkedIn</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/?share=reddit" target="_blank" title="Click to share on Reddit" ><span>Reddit</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon" href="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/?share=telegram" target="_blank" title="Click to share on Telegram" ><span>Telegram</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-103122" class="share-facebook sd-button share-icon" href="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/?share=facebook" target="_blank" title="Click to share on Facebook" ><span>Facebook</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/?share=pocket" target="_blank" title="Click to share on Pocket" ><span>Pocket</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="mailto:?subject=%5BShared%20Post%5D%20Look%20out%21%20Divergent%20representations%20are%20everywhere%21&body=https%3A%2F%2Fblog.trailofbits.com%2F2022%2F11%2F10%2Fdivergent-representations-variable-overflows-c-compiler%2F&share=email" target="_blank" title="Click to email a link to a friend" data-email-share-error-title="Do you have email set up?" data-email-share-error-text="If you&#039;re having problems sharing via email, you might not have email set up for your browser. You may need to create a new email yourself." data-email-share-nonce="f8a718badb" data-email-share-track-url="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/?share=email"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/#print" target="_blank" title="Click to print" ><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-3681601-103122-636d3c88145fb' data-src='https://widgets.wp.com/likes/#blog_id=3681601&amp;post_id=103122&amp;origin=blog.trailofbits.com&amp;obj_id=3681601-103122-636d3c88145fb' data-name='like-post-frame-3681601-103122-636d3c88145fb' data-title='Like or Reblog'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>			</div><!-- .entry-content -->

	<footer class="entry-footer">
		<p class="entry-byline">By tobgreg</p>
		<p class="cat-links">Posted in <a href="https://blog.trailofbits.com/category/binary-ninja/" rel="category tag">Binary Ninja</a>, <a href="https://blog.trailofbits.com/category/codeql/" rel="category tag">CodeQL</a>, <a href="https://blog.trailofbits.com/category/internship-projects/" rel="category tag">Internship Projects</a>, <a href="https://blog.trailofbits.com/category/research-practice/" rel="category tag">Research Practice</a>, <a href="https://blog.trailofbits.com/category/uncategorized/" rel="category tag">Uncategorized</a></p>
			</footer>
</article><!-- #post-103122 -->
						<nav role="navigation" id="nav-below" class="site-navigation post-navigation">
			<h1 class="assistive-text">Post navigation</h1>

		
			<div class="nav-previous"><a href="https://blog.trailofbits.com/2022/11/08/sigstore-code-signing-verification-software-supply-chain/" rel="prev"><span class="meta-nav">&larr;</span> We sign code now</a></div>			
		
		</nav><!-- #nav-below -->
		
					<div id="comments" class="comments-area">
	
	
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/11/10/divergent-representations-variable-overflows-c-compiler/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=3681601&#038;postid=103122&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;jetpack_comments_nonce=e5966298a2&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=11.6-a.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=4d38b640b22423402c377a848d2fe9598464f534#parent=https%3A%2F%2Fblog.trailofbits.com%2F2022%2F11%2F10%2Fdivergent-representations-variable-overflows-c-compiler%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments .comments-area -->

			
			</div><!-- #content -->
		</div><!-- #primary .site-content -->

		<div id="secondary" class="widget-area" role="complementary">
						<aside id="search-4" class="widget widget_search">	<form method="get" id="searchform" action="https://blog.trailofbits.com/" role="search">
		<label for="s" class="assistive-text">Search</label>
		<input type="search" class="field" name="s" id="s" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
	</form>
</aside><aside id="text-112416548" class="widget widget_text"><h1 class="widget-title">About Us</h1>			<div class="textwidget"><p>Since 2012, Trail of Bits has helped secure some of the world’s most targeted organizations and products. We combine high-­end security research with a real­ world attacker mentality to reduce risk and fortify code.</p>
<p>Read more at <a href="https://www.trailofbits.com">www.trailofbits.com</a></p>
</div>
		</aside><aside id="rss_links-4" class="widget widget_rss_links"><h1 class="widget-title">Subscribe via RSS</h1><p><a target="_self" href="https://blog.trailofbits.com/feed/" title="Subscribe to posts"><img src="https://blog.trailofbits.com/wp-content/plugins/jetpack/images/rss/red-small.png" alt="RSS feed" />&nbsp;RSS - Posts</a></p>
</aside>
		<aside id="recent-posts-5" class="widget widget_recent_entries">
		<h1 class="widget-title">Recent Posts</h1>
		<ul>
											<li>
					<a href="https://blog.trailofbits.com/2022/11/10/divergent-representations-variable-overflows-c-compiler/" aria-current="page">Look out! Divergent representations are everywhere!</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/11/08/sigstore-code-signing-verification-software-supply-chain/">We sign code now</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/10/25/sqlite-vulnerability-july-2022-library-api/">Stranger Strings: An exploitable flaw in SQLite</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/10/18/microsoft-windows-security-research-team/">We do Windows now</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/">Porting the Solana eBPF JIT compiler to ARM64</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/10/05/trail-of-bits-internship-blockchain-tealer/">Working on blockchains as a Trail of Bits intern</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/10/03/semgrep-maching-learning-static-analysis/">Secure your machine learning with Semgrep</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/09/15/it-pays-to-be-circomspect/">It pays to be Circomspect</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/08/25/magnifier-an-experiment-with-interactive-decompilation/">Magnifier: An Experiment with Interactive Decompilation</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/08/17/using-mutants-to-improve-slither/">Using mutants to improve Slither</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/08/12/the-road-to-the-apprenticeship/">The road to the apprenticeship</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/07/28/shedding-smart-contract-storage-with-slither/">Shedding smart contract storage with Slither</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/07/01/libmagic-the-blathering/">libmagic: The Blathering</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/06/30/a-typical-day-as-a-trail-of-bits-engineer-consultant/">A Typical Day as a Trail of Bits Engineer-Consultant</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/06/28/the-trail-of-bits-hiring-process/">The Trail of Bits Hiring Process</a>
									</li>
					</ul>

		</aside><aside id="text-112416546" class="widget widget_text"><h1 class="widget-title">Yearly Archive</h1>			<div class="textwidget"><ul>
<li><a href="https://blog.trailofbits.com/2020">2020</a></li>
<li><a href="https://blog.trailofbits.com/2019">2019</a></li>
<li><a href="https://blog.trailofbits.com/2018">2018</a></li>
<li><a href="https://blog.trailofbits.com/2017">2017</a></li>
<li><a href="https://blog.trailofbits.com/2016">2016</a></li>
<li><a href="https://blog.trailofbits.com/2015">2015</a></li>
<li><a href="https://blog.trailofbits.com/2014">2014</a></li>
<li><a href="https://blog.trailofbits.com/2013">2013</a></li>
<li><a href="https://blog.trailofbits.com/2012">2012</a></li>
</ul></div>
		</aside><aside id="categories-4" class="widget widget_categories"><h1 class="widget-title">Categories</h1>
			<ul>
					<li class="cat-item cat-item-291"><a href="https://blog.trailofbits.com/category/apple/">Apple</a> (13)
</li>
	<li class="cat-item cat-item-141319"><a href="https://blog.trailofbits.com/category/attacks/">Attacks</a> (10)
</li>
	<li class="cat-item cat-item-685590231"><a href="https://blog.trailofbits.com/category/audits/">Audits</a> (1)
</li>
	<li class="cat-item cat-item-44620"><a href="https://blog.trailofbits.com/category/authentication/">Authentication</a> (5)
</li>
	<li class="cat-item cat-item-502354744"><a href="https://blog.trailofbits.com/category/binary-ninja/">Binary Ninja</a> (13)
</li>
	<li class="cat-item cat-item-64575263"><a href="https://blog.trailofbits.com/category/blockchain/">Blockchain</a> (50)
</li>
	<li class="cat-item cat-item-1364812"><a href="https://blog.trailofbits.com/category/capture-the-flag/">Capture the Flag</a> (11)
</li>
	<li class="cat-item cat-item-685590242"><a href="https://blog.trailofbits.com/category/careers/">Careers</a> (2)
</li>
	<li class="cat-item cat-item-685590226"><a href="https://blog.trailofbits.com/category/codeql/">CodeQL</a> (3)
</li>
	<li class="cat-item cat-item-100030"><a href="https://blog.trailofbits.com/category/compilers/">Compilers</a> (23)
</li>
	<li class="cat-item cat-item-9204"><a href="https://blog.trailofbits.com/category/conferences/">Conferences</a> (28)
</li>
	<li class="cat-item cat-item-182564"><a href="https://blog.trailofbits.com/category/containers/">Containers</a> (2)
</li>
	<li class="cat-item cat-item-25818"><a href="https://blog.trailofbits.com/category/cryptography/">Cryptography</a> (40)
</li>
	<li class="cat-item cat-item-28634997"><a href="https://blog.trailofbits.com/category/crytic/">Crytic</a> (3)
</li>
	<li class="cat-item cat-item-199448218"><a href="https://blog.trailofbits.com/category/cyber-grand-challenge/">Cyber Grand Challenge</a> (7)
</li>
	<li class="cat-item cat-item-55871"><a href="https://blog.trailofbits.com/category/darpa/">DARPA</a> (21)
</li>
	<li class="cat-item cat-item-4181544"><a href="https://blog.trailofbits.com/category/dynamic-analysis/">Dynamic Analysis</a> (12)
</li>
	<li class="cat-item cat-item-1342"><a href="https://blog.trailofbits.com/category/education/">Education</a> (14)
</li>
	<li class="cat-item cat-item-551269408"><a href="https://blog.trailofbits.com/category/empire-hacking/">Empire Hacking</a> (7)
</li>
	<li class="cat-item cat-item-1360277"><a href="https://blog.trailofbits.com/category/engineering-practice/">Engineering Practice</a> (12)
</li>
	<li class="cat-item cat-item-924"><a href="https://blog.trailofbits.com/category/events/">Events</a> (5)
</li>
	<li class="cat-item cat-item-14563"><a href="https://blog.trailofbits.com/category/exploits/">Exploits</a> (27)
</li>
	<li class="cat-item cat-item-1643774"><a href="https://blog.trailofbits.com/category/fuzzing/">Fuzzing</a> (29)
</li>
	<li class="cat-item cat-item-2812"><a href="https://blog.trailofbits.com/category/go/">Go</a> (4)
</li>
	<li class="cat-item cat-item-320"><a href="https://blog.trailofbits.com/category/guides/">Guides</a> (9)
</li>
	<li class="cat-item cat-item-25357667"><a href="https://blog.trailofbits.com/category/internship-projects/">Internship Projects</a> (31)
</li>
	<li class="cat-item cat-item-96379492"><a href="https://blog.trailofbits.com/category/iverify/">iVerify</a> (4)
</li>
	<li class="cat-item cat-item-46713213"><a href="https://blog.trailofbits.com/category/kubernetes/">Kubernetes</a> (2)
</li>
	<li class="cat-item cat-item-610"><a href="https://blog.trailofbits.com/category/linux/">Linux</a> (1)
</li>
	<li class="cat-item cat-item-685590236"><a href="https://blog.trailofbits.com/category/machine-learning/">Machine Learning</a> (6)
</li>
	<li class="cat-item cat-item-15593"><a href="https://blog.trailofbits.com/category/malware/">Malware</a> (7)
</li>
	<li class="cat-item cat-item-1056516"><a href="https://blog.trailofbits.com/category/manticore/">Manticore</a> (15)
</li>
	<li class="cat-item cat-item-245013018"><a href="https://blog.trailofbits.com/category/mcsema/">McSema</a> (11)
</li>
	<li class="cat-item cat-item-171"><a href="https://blog.trailofbits.com/category/meta/">Meta</a> (12)
</li>
	<li class="cat-item cat-item-6701995"><a href="https://blog.trailofbits.com/category/mitigations/">Mitigations</a> (9)
</li>
	<li class="cat-item cat-item-293462444"><a href="https://blog.trailofbits.com/category/osquery/">osquery</a> (22)
</li>
	<li class="cat-item cat-item-208532"><a href="https://blog.trailofbits.com/category/paper-review/">Paper Review</a> (11)
</li>
	<li class="cat-item cat-item-685590244"><a href="https://blog.trailofbits.com/category/people/">People</a> (1)
</li>
	<li class="cat-item cat-item-685590238"><a href="https://blog.trailofbits.com/category/podcast/">Podcast</a> (1)
</li>
	<li class="cat-item cat-item-6672"><a href="https://blog.trailofbits.com/category/press-release/">Press Release</a> (26)
</li>
	<li class="cat-item cat-item-3279"><a href="https://blog.trailofbits.com/category/privacy/">Privacy</a> (9)
</li>
	<li class="cat-item cat-item-1589"><a href="https://blog.trailofbits.com/category/products/">Products</a> (6)
</li>
	<li class="cat-item cat-item-5030448"><a href="https://blog.trailofbits.com/category/program-analysis/">Program Analysis</a> (16)
</li>
	<li class="cat-item cat-item-685590239"><a href="https://blog.trailofbits.com/category/recruitment/">Recruitment</a> (1)
</li>
	<li class="cat-item cat-item-685590241"><a href="https://blog.trailofbits.com/category/remote-work/">Remote Work</a> (1)
</li>
	<li class="cat-item cat-item-113884"><a href="https://blog.trailofbits.com/category/research-practice/">Research Practice</a> (19)
</li>
	<li class="cat-item cat-item-299073"><a href="https://blog.trailofbits.com/category/reversing/">Reversing</a> (14)
</li>
	<li class="cat-item cat-item-185574"><a href="https://blog.trailofbits.com/category/rust/">Rust</a> (4)
</li>
	<li class="cat-item cat-item-685590219"><a href="https://blog.trailofbits.com/category/safedocs/">SafeDocs</a> (1)
</li>
	<li class="cat-item cat-item-685590218"><a href="https://blog.trailofbits.com/category/sinter/">Sinter</a> (1)
</li>
	<li class="cat-item cat-item-685590237"><a href="https://blog.trailofbits.com/category/slither/">Slither</a> (2)
</li>
	<li class="cat-item cat-item-401665"><a href="https://blog.trailofbits.com/category/sponsorships/">Sponsorships</a> (12)
</li>
	<li class="cat-item cat-item-538062"><a href="https://blog.trailofbits.com/category/static-analysis/">Static Analysis</a> (28)
</li>
	<li class="cat-item cat-item-19674948"><a href="https://blog.trailofbits.com/category/symbolic-execution/">Symbolic Execution</a> (17)
</li>
	<li class="cat-item cat-item-943"><a href="https://blog.trailofbits.com/category/training/">Training</a> (1)
</li>
	<li class="cat-item cat-item-1"><a href="https://blog.trailofbits.com/category/uncategorized/">Uncategorized</a> (23)
</li>
	<li class="cat-item cat-item-685590240"><a href="https://blog.trailofbits.com/category/working-at-trail-of-bits/">Working at Trail of Bits</a> (2)
</li>
	<li class="cat-item cat-item-29911"><a href="https://blog.trailofbits.com/category/year-in-review/">Year in Review</a> (4)
</li>
	<li class="cat-item cat-item-685590235"><a href="https://blog.trailofbits.com/category/zero-knowledge/">Zero Knowledge</a> (8)
</li>
			</ul>

			</aside><aside id="twitter_timeline-3" class="widget widget_twitter_timeline"><a class="twitter-timeline" data-height="400" data-theme="light" data-border-color="#e8e8e8" data-tweet-limit="8" data-lang="EN" data-partner="jetpack" data-chrome="nofooter transparent" href="https://twitter.com/trailofbits" href="https://twitter.com/trailofbits">My Tweets</a></aside>		</div><!-- #secondary .widget-area -->

	</div><!-- #main -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
						<a></a>
			
					</div><!-- .site-info -->
	</footer><!-- .site-footer .site-footer -->
</div><!-- #page .hfeed .site -->

<!--  -->
<script defer id="bilmur" data-provider="wordpress.com" data-service="atomic"  src="https://s0.wp.com/wp-content/js/bilmur.min.js?m=202245"></script>
		<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.trailofbits.com\/2022\/11\/10\/divergent-representations-variable-overflows-c-compiler\/":103122};
	</script>
				<script type='text/javascript'  src='https://blog.trailofbits.com/_static/??-eJwrL9BNzs8rSc0r0S/IKU3PzCvWL67MK0msyMhMz8gB4pLUIkwRY/3i5KLMghKg4gzn/KJUvaxinXKKTXIqKi3OCMhJzMwDmmefa2toZmpkbmxsZmAMAIcdP60='></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://blog.trailofbits.com/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		document.head.appendChild( corecss );
		var themecssurl = "https://blog.trailofbits.com/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeDefault.css?ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		document.head.appendChild( themecss );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ expand source';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Can\'t find brush for: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Brush wasn\'t configured for html-script option: ';
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.all();

	// Infinite scroll support
	if ( typeof( jQuery ) !== 'undefined' ) {
		jQuery( function( $ ) {
			$( document.body ).on( 'post-load', function() {
				SyntaxHighlighter.highlight();
			} );
		} );
	}
</script>
<link rel='stylesheet' id='all-css-d77622eb680dd7b9b8dd63b8c4d730db' href='https://blog.trailofbits.com/_static/??-eJyVjFsKgCAQAC+UbWYEfURnMV3C8oXr4vUjqAP0O8NMy8KkWDFWyJ4PFwlOrFmbC0Ky7JHA6JKY0AM1l7GInaP12Buirv2oXyE+8Ay2sMpZyWFcpJpuzec0Gg==' type='text/css' media='all' />
<script id='jetpack-lazy-images-js-extra'>
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
</script>
<script id='jetpack-carousel-js-extra'>
var jetpackSwiperLibraryPath = {"url":"https:\/\/blog.trailofbits.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.trailofbits.com\/wp-admin\/admin-ajax.php","nonce":"4f4e5987d9","display_exif":"0","display_comments":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/blog.trailofbits.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.trailofbits.com%2F2022%2F11%2F10%2Fdivergent-representations-variable-overflows-c-compiler%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
</script>
<script type='text/javascript'  src='https://blog.trailofbits.com/_static/??-eJytUNFOwzAM/CGyCA2VvSA+ZUoTs7p1nJA4q7qvJxvZhgBNQ+LJyvnucuc5KhtYgEVHKjvkrEeQaOykt8hW9wXJ6TgECdzGyiOvxvww/5Ta0FOwU9YOs+jxCijD6I1g+K6UATxkDXtIizPLUZO9IVIeuDRuzUHFVdbJ0NeNqASRlhtJfikhM4pAUoIeCBnuULe53QO7kLQpEmoLQXveKDKHRdVqO2ilsTqlDPbYVYU+Q6rV/v+bL8D9FyCcqv69QIHBsKMa7E8XtCaFkoEusc7ADRszYfYgnzbtod7SieWq5tW/PHbd0/p5s1l3HyfD+dw='></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script src='https://blog.trailofbits.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=11.6-a.1' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-telegram' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-telegram' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-pocket' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-pocket' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202245#ver=202245' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=3681601&postid=103122&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&jetpack_comments_nonce=e5966298a2&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.6-a.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=4d38b640b22423402c377a848d2fe9598464f534#parent=https%3A%2F%2Fblog.trailofbits.com%2F2022%2F11%2F10%2Fdivergent-representations-variable-overflows-c-compiler%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=3681601&postid=103122&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&jetpack_comments_nonce=e5966298a2&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.6-a.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=4d38b640b22423402c377a848d2fe9598464f534#parent=https%3A%2F%2Fblog.trailofbits.com%2F2022%2F11%2F10%2Fdivergent-representations-variable-overflows-c-compiler%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>

			<script src='https://stats.wp.com/e-202245.js' defer></script>
	<script>
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'3681601',post:'103122',tz:'-5',srv:'blog.trailofbits.com',hp:'atomic',ac:'2',amp:'0',j:'1:11.6-a.1'} ]);
		_stq.push([ 'clickTrackerInit', '3681601', '103122' ]);
	</script>
</body>
</html>
<!--
	generated 109 seconds ago
	generated in 0.172 seconds
	served from batcache in 0.002 seconds
	expires in 191 seconds
-->
