<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>Porting the Solana eBPF JIT compiler to ARM64 | Trail of Bits Blog</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://blog.trailofbits.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://blog.trailofbits.com/wp-content/themes/everyday/js/html5.js" type="text/javascript"></script>
<![endif]-->

<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="Lbyyor8qrpJf-6qi1ql45JDKAmXUIcc3N0mFeVNwUok" />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Trail of Bits Blog &raquo; Feed" href="https://blog.trailofbits.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Trail of Bits Blog &raquo; Comments Feed" href="https://blog.trailofbits.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Trail of Bits Blog &raquo; Porting the Solana eBPF JIT compiler to ARM64 Comments Feed" href="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.trailofbits.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-04d5b01cca70c3aecb7a624231e4b791' href='https://blog.trailofbits.com/_static/??-eJyFUVtuAyEMvFCJW6lKv6r+ROoBeoCKBYs4MRhhyHZvXzaPKkmbhi8PeIbxeMzGSaqYKmRugZJCaB0OWAIMjdjDwOK2hmkotkygdWJcONWH8TeV7SStmlDIXzZSctw8KmwUInqyyBhn5jnInY7FMAbrpkWkdJfd387xOedkLTZzcjdmJ1HXsMPkpYBtVaKtlRxU/KoHJTOSD1jN3r1CF4Pjzdxza+7ryPo/WVLv0P/zcrIPV+FnwhXm7g6Tow7eZWW9n+DjYOagzbai3nSywZqt20IU32YO0xZvmKjrHpoC7rBM3t7Z7LWurm1Bv3c3l5TCPeZnnxFUHFk2LEH0Avy1umuFeRnHem59i69Py+Xz80s/j99J5hDb' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='dashicons-css'  href='https://blog.trailofbits.com/wp-includes/css/dashicons.min.css?ver=6.0.2' media='all' />
<link rel='stylesheet' id='everyday-droid-serif-css'  href='https://fonts.googleapis.com/css?family=Droid+Serif%3A400%2C700%2C400italic%2C700italic&#038;ver=20120328' media='all' />
<link rel='stylesheet' id='everyday-droid-sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3A400%2C700&#038;ver=20120328' media='all' />
<link rel='stylesheet' id='everyday-droid-mono-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans+Mono&#038;ver=20120328' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<script src='https://blog.trailofbits.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript'  src='https://blog.trailofbits.com/wp-includes/js/jquery/jquery-migrate.min.js?m=1605690366'></script>
<link rel="https://api.w.org/" href="https://blog.trailofbits.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.trailofbits.com/wp-json/wp/v2/posts/102908" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.trailofbits.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.trailofbits.com/wp-includes/wlwmanifest.xml" /> 

<link rel="canonical" href="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/" />
<link rel='shortlink' href='https://blog.trailofbits.com/?p=102908' />
<link rel="alternate" type="application/json+oembed" href="https://blog.trailofbits.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.trailofbits.com%2F2022%2F10%2F12%2Fsolana-jit-compiler-ebpf-arm64%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.trailofbits.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.trailofbits.com%2F2022%2F10%2F12%2Fsolana-jit-compiler-ebpf-arm64%2F&#038;format=xml" />
	<style>img#wpstats{display:none}</style>
		<style>
#page {
	background-color: #f7f7f7;
}
</style>

<meta name="description" content="By Andrew Haberlandt  During my summer internship at Trail of Bits, I worked on the fork of the RBPF JIT compiler that is used to execute Solana smart contracts. The RBPF JIT compiler plays a critical role on the Solana blockchain, as it facilitates the execution of contracts on validator nodes by default. Before my&hellip;" />
<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("https://blog.trailofbits.com/wp-content/themes/everyday/images/background.png"); background-position: left top; background-size: auto; background-repeat: repeat; background-attachment: scroll; }
</style>
				<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Porting the Solana eBPF JIT compiler to ARM64" />
<meta property="og:url" content="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/" />
<meta property="og:description" content="By Andrew Haberlandt  During my summer internship at Trail of Bits, I worked on the fork of the RBPF JIT compiler that is used to execute Solana smart contracts. The RBPF JIT compiler plays a criti…" />
<meta property="article:published_time" content="2022-10-12T12:00:55+00:00" />
<meta property="article:modified_time" content="2022-10-07T21:33:44+00:00" />
<meta property="og:site_name" content="Trail of Bits Blog" />
<meta property="og:image" content="https://blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png" />
<meta property="og:image:width" content="224" />
<meta property="og:image:height" content="390" />
<meta property="og:image:alt" content="" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@trailofbits" />
<meta name="twitter:site" content="@trailofbits" />
<meta name="twitter:text:title" content="Porting the Solana eBPF JIT compiler to ARM64" />
<meta name="twitter:image" content="https://blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?w=144" />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2020/07/cropped-android-chrome-512x512-1.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2020/07/cropped-android-chrome-512x512-1.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2020/07/cropped-android-chrome-512x512-1.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2020/07/cropped-android-chrome-512x512-1.png?fit=270%2C270&#038;ssl=1" />
<style type="text/css" id="wp-custom-css">/*
Welcome to Custom CSS!

To learn how this works, see http://wp.me/PEmnE-Bt
*/
.entry-content {
	padding-left: 0;
}

.entry-content
blockquote {
	margin-left: 25px;
}

.entry-content
.embed {
	margin-left: 0;
}

.entry-content
.embed-youtube {
	margin-left: 0;
}

/* To remove the infinite scroll footer HC-23308875-SK */
#infinite-footer
{
  display:none;
}

.wp-caption 
.wp-caption-text {
	text-align: center;
}</style><!-- Your Google Analytics Plugin is missing the tracking ID -->
</head>

<body class="post-template-default single single-post postid-102908 single-format-standard custom-background group-blog">
<div id="page" class="hfeed site">
		<header id="masthead" class="site-header" role="banner">
		<hgroup>
			<h1 class="site-title"><a href="https://blog.trailofbits.com/" title="Trail of Bits Blog" rel="home">Trail of Bits Blog</a></h1>
			<h2 class="site-description"></h2>
					</hgroup>

		<nav role="navigation" class="site-navigation main-navigation">
			<h1 class="assistive-text">Menu</h1>
			<div class="assistive-text skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>
			<div class="menu"><ul>
<li ><a href="https://blog.trailofbits.com/">Home</a></li></ul></div>
		</nav>
	</header><!-- #masthead .site-header -->

	<div id="main" class="main">
		<div id="primary" class="site-content">
			<div id="content" role="main">

			
				
<article id="post-102908" class="post-102908 post type-post status-publish format-standard hentry category-blockchain category-crytic category-engineering-practice category-internship-projects category-uncategorized entry">
	<header class="entry-header">

		<h1 class="entry-title">Porting the Solana eBPF JIT compiler to ARM64</h1>
					<ul class="entry-meta">
				<li class="entry-format">Post</li>
				<li class="permalink"><a href="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/" title="8:00 am" rel="bookmark"><time class="entry-date" datetime="2022-10-12T08:00:55-04:00" pubdate>October 12, 2022</time></a></li>
				<li class="comment-link"><a href="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/#respond">Leave a comment</a></li>
							</ul><!-- .entry-meta -->
			</header><!-- .entry-header -->

	<div class="entry-content">
		<p><strong>By Andrew Haberlandt </strong></p>
<p>During my summer internship at Trail of Bits, I worked on the fork of the <a href="https://github.com/solana-labs/rbpf" target="_blank" rel="noopener">RBPF JIT compiler</a> that is used to execute Solana smart contracts. The RBPF JIT compiler plays a critical role on the Solana blockchain, as it facilitates the execution of contracts on validator nodes by default.</p>
<p>Before my work on this project, RBPF supported JIT mode only on x86 hosts. An increasing number of developers are using ARM64 machines, but are unable to run their test in JIT mode. My primary goal was to add support in RBPF for the ARM64 architecture, mainly by updating the register map, calling convention, and all of the subroutines and instruction translations to emit ARM64 instructions. I also aimed to implement support for Windows in the RBPF x86 JIT compiler.</p>
<p>The work is live and can be found <a href="https://github.com/solana-labs/rbpf/pull/358" target="_blank" rel="noopener">in two</a> <a href="https://github.com/solana-labs/rbpf/pull/359" target="_blank" rel="noopener">pull requests </a>on Solana’s GitHub page. However, a caveat: it is currently <a href="https://github.com/solana-labs/rbpf/pull/358/files#diff-7d39efd566d08b201d1e747f11b3909be0d39fd3d4c89cfd28e0b21bab3ec27aR187" target="_blank" rel="noopener">behind a feature-gate</a> (<code>'jit-aarch64-not-safe-for-production'</code>) and is not ready for production until it has received a thorough peer review.</p>
<h2>Background</h2>
<p>Smart contracts that run on the Solana blockchain are compiled from Rust (or C, if you like bugs) to eBPF, an extended version of the Berkeley Packet Filter. The eBPF virtual machine’s architecture is fairly simple, with a minimal set of 32- and 64-bit integer operations (including multiplication and division) and memory and control flow instructions. BPF programs have their own address space, which in RBPF consists of code, stack, heap, and input data sections located at fixed addresses.</p>
<p>The version of BPF supported by RBPF was designed to work with programs compiled using the LLVM BPF back end. <a href="https://www.kernel.org/doc/html/latest/bpf/instruction-set.html" target="_blank" rel="noopener">The official Linux documentation</a> for eBPF shows that there are a few differences between RBPF and eBPF—most notably, RBPF has to support an indirect call (<code>callx</code>) instruction.</p>
<p>Furthermore, RBPF’s “verifier” is much simpler than that of eBPF. In the Linux kernel, the eBPF verifier validates <a href="https://www.graplsecurity.com/post/kernel-pwning-with-ebpf-a-love-story#toc-0" target="_blank" rel="noopener">certain safety properties</a> of BPF programs before JITing and executing them. In RBPF, Solana programs pass through a much simpler verifier before being JITed. The verifier checks for instructions that try to divide by a constant zero, jump to a clearly invalid address, or read or write to an invalid register, among other errors. Notably, the RBPF verifier does not perform any CFG analysis or attempt to track the range of values held by each register. The full list of errors that the RBPF verifier checks for can be found <a href="https://github.com/solana-labs/rbpf/blob/1c1556e166378eeca10cffe26cbcbf79c918431d/src/verifier.rs#L31" target="_blank" rel="noopener">here</a>.</p>
<h2>RBPF internals</h2>
<div id="attachment_102914" style="width: 700px" class="wp-caption aligncenter"><a href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?ssl=1"><img aria-describedby="caption-attachment-102914" data-attachment-id="102914" data-permalink="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/on-chain-2/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?fit=1362%2C491&amp;ssl=1" data-orig-size="1362,491" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="(on-chain)" data-image-description data-image-caption="&lt;p&gt;The source code to binary translation stages&lt;/p&gt;
" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?fit=300%2C108&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?fit=690%2C249&amp;ssl=1" class="size-large wp-image-102914 jetpack-lazy-image" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?resize=690%2C249&#038;ssl=1" alt width="690" height="249" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?resize=1024%2C369&amp;ssl=1 1024w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?resize=300%2C108&amp;ssl=1 300w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?resize=768%2C277&amp;ssl=1 768w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?resize=1200%2C433&amp;ssl=1 1200w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?w=1362&amp;ssl=1 1362w" data-lazy-sizes="(max-width: 690px) 100vw, 690px" data-lazy-src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?resize=690%2C249&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" aria-describedby="caption-attachment-102914" data-attachment-id="102914" data-permalink="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/on-chain-2/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?fit=1362%2C491&amp;ssl=1" data-orig-size="1362,491" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="(on-chain)" data-image-description="" data-image-caption="&lt;p&gt;The source code to binary translation stages&lt;/p&gt;
" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?fit=300%2C108&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?fit=690%2C249&amp;ssl=1" class="size-large wp-image-102914" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?resize=690%2C249&#038;ssl=1" alt="" width="690" height="249" srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?resize=1024%2C369&amp;ssl=1 1024w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?resize=300%2C108&amp;ssl=1 300w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?resize=768%2C277&amp;ssl=1 768w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?resize=1200%2C433&amp;ssl=1 1200w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/on-chain-1.png?w=1362&amp;ssl=1 1362w" sizes="(max-width: 690px) 100vw, 690px" data-recalc-dims="1"  /></noscript></a><p id="caption-attachment-102914" class="wp-caption-text">The source code to binary translation stages</p></div>
<p>RBPF verifies then translates an entire program, instruction by instruction, into the target architecture before finally calling into the emitted code. This involves an eBPF instruction decoder and a partial instruction encoder for the target architecture (before the summer of 2022, only x86 was supported). RBPF also provides an interpreter capable of executing eBPF Solana programs, but the JITed translations are the default for performance reasons.</p>
<h3>Memory and address translation</h3>
<p>BPF programs are executed in their own memory space, and there is a mapping between this address space and the host address space. Memory regions are set up (using <code>mmap</code> and <code>mprotect</code>) for each program that is to be executed; the BPF code, stack, heap, and input data have their own regions, located at <a href="https://github.com/solana-labs/rbpf/blob/1c1556e166378eeca10cffe26cbcbf79c918431d/src/ebpf.rs#L51" target="_blank" rel="noopener">fixed addresses</a> in BPF address space. The locations of these mappings in the host address space are not fixed.</p>
<div id="attachment_102917" style="width: 771px" class="wp-caption aligncenter"><a href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/0x100000000.png?ssl=1"><img aria-describedby="caption-attachment-102917" data-attachment-id="102917" data-permalink="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/0x100000000/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/0x100000000.png?fit=761%2C432&amp;ssl=1" data-orig-size="761,432" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="0x100000000" data-image-description data-image-caption="&lt;p&gt;The memory layout of the vm environment&lt;/p&gt;
" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/0x100000000.png?fit=300%2C170&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/0x100000000.png?fit=690%2C392&amp;ssl=1" class="size-full wp-image-102917 jetpack-lazy-image" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/0x100000000.png?resize=690%2C392&#038;ssl=1" alt width="690" height="392" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/0x100000000.png?w=761&amp;ssl=1 761w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/0x100000000.png?resize=300%2C170&amp;ssl=1 300w" data-lazy-sizes="(max-width: 690px) 100vw, 690px" data-lazy-src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/0x100000000.png?resize=690%2C392&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" aria-describedby="caption-attachment-102917" data-attachment-id="102917" data-permalink="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/0x100000000/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/0x100000000.png?fit=761%2C432&amp;ssl=1" data-orig-size="761,432" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="0x100000000" data-image-description="" data-image-caption="&lt;p&gt;The memory layout of the vm environment&lt;/p&gt;
" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/0x100000000.png?fit=300%2C170&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/0x100000000.png?fit=690%2C392&amp;ssl=1" loading="lazy" class="size-full wp-image-102917" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/0x100000000.png?resize=690%2C392&#038;ssl=1" alt="" width="690" height="392" srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/0x100000000.png?w=761&amp;ssl=1 761w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/0x100000000.png?resize=300%2C170&amp;ssl=1 300w" sizes="(max-width: 690px) 100vw, 690px" data-recalc-dims="1"  /></noscript></a><p id="caption-attachment-102917" class="wp-caption-text">The memory layout of the vm environment</p></div>
<p>To handle eBPF load and store instructions, the address must first be translated into the host address space. RBPF includes a <code>translate_memory_address</code> assembly routine, which is responsible for looking up the region that contains the address being accessed and for translating the BPF address into a host address. This translation logic is invoked every time a BPF load or store instruction is executed, as shown in the example instruction translations later in this post.</p>
<h3>Register allocation</h3>
<p>BPF has 11 registers (10 general purpose registers and the frame pointer), each of which <a href="https://github.com/solana-labs/rbpf/blob/main/src/jit.rs#L218" target="_blank" rel="noopener">maps to a distinct register</a> in the host architecture. On x86_64, which has 16 registers, four of the remaining registers are used for specific purposes (RSP cannot be repurposed, since the original host call stack will be maintained), described below:</p>
<pre class="brush: plain; title: ; notranslate" title="">
// Special registers:
//     ARGUMENT_REGISTERS[0]  RDI  BPF program counter limit (used by instruction meter)
// CALLER_SAVED_REGISTERS[8]  R11  Scratch register
// CALLER_SAVED_REGISTERS[7]  R10  Constant pointer to JitProgramArgument (also scratch register for exception handling)
// CALLEE_SAVED_REGISTERS[0]  RBP  Constant pointer to initial RSP - 8

</pre>
<p>Source: <a href="https://github.com/solana-labs/rbpf/blob/main/src/jit.rs#L224" target="_blank" rel="noopener">Line 224 of jit.rs in solana-labs</a></p>
<h3>Instruction translation</h3>
<p>Translating instructions in RBPF is a fairly straightforward process:</p>
<ul>
<li>Registers in the eBPF virtual machine are mapped to a unique register in the host architecture.</li>
<li>Each opcode is translated to one or more instructions in the host architecture (via this large match statement).</li>
</ul>
<p>Two example translations are displayed below:</p>
<div id="attachment_102923" style="width: 700px" class="wp-caption aligncenter"><a href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?ssl=1"><img aria-describedby="caption-attachment-102923" data-attachment-id="102923" data-permalink="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/mova_rax/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?fit=1404%2C682&amp;ssl=1" data-orig-size="1404,682" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mova_rax" data-image-description data-image-caption="&lt;p&gt;Example instruction translations&lt;/p&gt;
" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?fit=300%2C146&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?fit=690%2C335&amp;ssl=1" class="size-large wp-image-102923 jetpack-lazy-image" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?resize=690%2C335&#038;ssl=1" alt width="690" height="335" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?resize=1024%2C497&amp;ssl=1 1024w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?resize=300%2C146&amp;ssl=1 300w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?resize=768%2C373&amp;ssl=1 768w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?resize=1200%2C583&amp;ssl=1 1200w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?w=1404&amp;ssl=1 1404w" data-lazy-sizes="(max-width: 690px) 100vw, 690px" data-lazy-src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?resize=690%2C335&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" aria-describedby="caption-attachment-102923" data-attachment-id="102923" data-permalink="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/mova_rax/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?fit=1404%2C682&amp;ssl=1" data-orig-size="1404,682" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mova_rax" data-image-description="" data-image-caption="&lt;p&gt;Example instruction translations&lt;/p&gt;
" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?fit=300%2C146&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?fit=690%2C335&amp;ssl=1" loading="lazy" class="size-large wp-image-102923" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?resize=690%2C335&#038;ssl=1" alt="" width="690" height="335" srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?resize=1024%2C497&amp;ssl=1 1024w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?resize=300%2C146&amp;ssl=1 300w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?resize=768%2C373&amp;ssl=1 768w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?resize=1200%2C583&amp;ssl=1 1200w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/mova_rax.png?w=1404&amp;ssl=1 1404w" sizes="(max-width: 690px) 100vw, 690px" data-recalc-dims="1"  /></noscript></a><p id="caption-attachment-102923" class="wp-caption-text">Example instruction translations</p></div>
<p>RBPF includes subroutines that are emitted once to handle shared logic (such as address translation, which is performed by translating the load instruction above). Sometimes these subroutines include calls back into Rust code to handle more complicated operations (e.g., tracing, “syscalls”) or to update certain externally visible states (e.g., the instruction meter). There is also a prologue (e.g., to set up the stack, handle exceptions, etc.) and an epilogue (e.g., to handle cases in which the execution reaches the last instruction in the program and does not exit, which is normally done by calling an exit function).</p>
<div id="attachment_102925" style="width: 234px" class="wp-caption aligncenter"><a href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?ssl=1"><img aria-describedby="caption-attachment-102925" data-attachment-id="102925" data-permalink="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/kwtmvavljmg4gboon2e5c9-cs6obsfsbc5hn0qadxdbzkrx54pvvuxolaaetnamzf1uzpjd9d8hhvpz9af_juhylk7cfyanp0trltckkdkk1j49-17btm3pfd9aa/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?fit=224%2C390&amp;ssl=1" data-orig-size="224,390" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa" data-image-description data-image-caption="&lt;p&gt;The memory layout of the JIT code region &lt;/p&gt;
" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?fit=172%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?fit=224%2C390&amp;ssl=1" class="size-full wp-image-102925 jetpack-lazy-image" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?resize=224%2C390&#038;ssl=1" alt width="224" height="390" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?w=224&amp;ssl=1 224w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?resize=172%2C300&amp;ssl=1 172w" data-lazy-sizes="(max-width: 224px) 100vw, 224px" data-lazy-src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?resize=224%2C390&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" aria-describedby="caption-attachment-102925" data-attachment-id="102925" data-permalink="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/kwtmvavljmg4gboon2e5c9-cs6obsfsbc5hn0qadxdbzkrx54pvvuxolaaetnamzf1uzpjd9d8hhvpz9af_juhylk7cfyanp0trltckkdkk1j49-17btm3pfd9aa/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?fit=224%2C390&amp;ssl=1" data-orig-size="224,390" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa" data-image-description="" data-image-caption="&lt;p&gt;The memory layout of the JIT code region &lt;/p&gt;
" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?fit=172%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?fit=224%2C390&amp;ssl=1" loading="lazy" class="size-full wp-image-102925" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?resize=224%2C390&#038;ssl=1" alt="" width="224" height="390" srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?w=224&amp;ssl=1 224w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/KWTMVavLjMg4Gboon2e5C9-cs6ObsfSbc5hn0qADxDBZKrX54pvvuxolaAetNAMzF1UzPjD9d8HhVpZ9aF_JuHYlk7CfYAnp0trLtCkKdkk1j49-17btM3pfd9Aa.png?resize=172%2C300&amp;ssl=1 172w" sizes="(max-width: 224px) 100vw, 224px" data-recalc-dims="1"  /></noscript></a><p id="caption-attachment-102925" class="wp-caption-text">The memory layout of the JIT code region</p></div>
<h3>Control flow</h3>
<p>Every BPF instruction is a valid target address for a jump or call. eBPF instructions are 8 bytes, with one exception: load double word (LDDW), which is 16 bytes. This means that, with this one exception, every 8-byte boundary in the BPF code address space is a valid jump target.</p>
<p>Relative jumps can always be resolved before runtime; they can either be resolved at <a href="https://github.com/solana-labs/rbpf/blob/8d95c0e20a2d9b5eeca0b98da27178e1df75aeb7/src/jit.rs#L1715" target="_blank" rel="noopener">translation-time</a> (for backward jumps) or be <a href="https://github.com/solana-labs/rbpf/blob/8d95c0e20a2d9b5eeca0b98da27178e1df75aeb7/src/jit.rs#L1727" target="_blank" rel="noopener">‘fixed up’</a> after all instructions have been emitted (for forward jumps). Indirect calls, however, must be resolved at runtime. Therefore, RBPF keeps a mapping from the instruction index to the host address so that the location of the already-translated target instruction can be looked up when an indirect call occurs.</p>
<h3>The instruction meter</h3>
<p>Solana programs are designed to run with a specific ‘compute budget’, which is essentially the number of eBPF instructions that can be executed before the program exits. In order to enforce this limit (on potentially non-terminating programs), the JIT compiler emits additional logic to track the number of instructions that have been executed. The instruction meter is best described in <a href="https://github.com/solana-labs/rbpf/blob/main/src/jit.rs#L404" target="_blank" rel="noopener">this comment</a>, but it can be summarized as follows:</p>
<ul>
<li>The <em>source</em> of each branch is instrumented to account for the instructions that were executed in the linear sequence since the last update and to record the branch target (the beginning of the next linear sequence of instructions to execute).</li>
<li>If a conditional branch is not actually taken, the updates to the instruction meter are undone.</li>
<li>Additional instruction meter checks are inserted at certain thresholds in long linear sequences of instructions.</li>
</ul>
<p>The instruction meter has been the source of multiple bugs in the past (e.g., check out <a href="http://pull request 203" target="_blank" rel="noopener">pull request 203</a> and <a href="https://github.com/solana-labs/rbpf/pull/263" target="_blank" rel="noopener">pull request 263</a>).</p>
<h3>Calls and “syscalls”</h3>
<p>For regular eBPF calls within the same program, RBPF keeps a separate stack from the host (currently using fixed-size stack frames), tracks the current call depth, and exits with an error if the call depth exceeds its budget. Solana programs in particular also need to invoke other contracts and interact with certain blockchain states. RBPF has a mechanism called <a href="https://github.com/solana-labs/solana/tree/master/programs/bpf_loader/src/syscalls" target="_blank" rel="noopener">“syscalls”</a> by which eBPF programs can make calls into Solana-specific helper functions implemented in Rust.</p>
<h3>Exceptions</h3>
<p>The JIT compiler may exit early if it encounters a number of unrecoverable runtime conditions (such as division by zero or invalid memory access). Since the verifier does not attempt to track register content, most exceptions are caught at runtime rather than at verification time. Exception handlers are designed to record the current exception information into an <code>EbpfError</code> enum and then proceed to the exit the subroutine (which returns back into Rust code).</p>
<h3>Security mitigations</h3>
<p>RBPF contains a few features that fall under the category of “machine code diversification” and serve to somewhat harden the JIT compiler against exploitation. Two of the features (introduced last year) are <a href="https://github.com/solana-labs/rbpf/pull/143" target="_blank" rel="noopener">constant sanitization and instruction address randomization</a>.</p>
<p>Constant sanitization changes how immediates are loaded into registers in the emitted code. Rather than emitting a typical x86 MOVABS instruction, which would contain the unmodified bytes of the immediate, the immediate is instead offset by a randomly generated key. At runtime, this key is fetched from memory in a subsequent instruction and added so that the destination register contains the originally desired immediate.</p>
<p>Instruction address randomization adds no-op instructions at random locations throughout the emitted code. Both of these mitigations are intended to make code-reuse attacks more difficult.</p>
<h2>Porting RBPF to ARM64</h2>
<h3>Calling convention and register allocation</h3>
<p>The JIT compiler needs to be able to call into Rust code, which will follow the host’s calling convention. Luckily, most platforms follow the <a href="https://github.com/ARM-software/abi-aa/blob/60a8eb8c55e999d74dac5e368fc9d7e36e38dda4/aapcs64/aapcs64.rst#machine-registers" target="_blank" rel="noopener">ARM software standard</a> for the calling convention. Both <a href="https://developer.apple.com/documentation/xcode/writing-arm64-code-for-apple-platforms" target="_blank" rel="noopener">Apple</a> and <a href="https://docs.microsoft.com/en-us/cpp/build/arm64-windows-abi-conventions?view=msvc-170" target="_blank" rel="noopener">Microsoft</a> publish their own ABI documentation, but they mostly follow the standard ARM64 documentation. I tested my implementation on M1 running macOS and on an emulated ARM64 virtual machine through QEMU.</p>
<p>Note that ARM64’s additional registers mean that even after mapping each eBPF register to a host register, there is a substantial number of extra unused host registers. I used some of these extra registers to hold additional “scratch” values during the translation of more complex instructions. Additional scratch values are often helpful since only load and store instructions can access memory in ARM64, which often results in longer translations with more temporary values.</p>
<h3>Instruction-by-instruction translation</h3>
<p>I wrote translations to ARM64 for each of the eBPF instructions, modeled closely after their x86 translations. The following is an example of the existing x86 and the new translated ARM64 code for two variants of the eBPF ADD instruction.</p>
<div id="attachment_102936" style="width: 700px" class="wp-caption aligncenter"><a href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?ssl=1"><img aria-describedby="caption-attachment-102936" data-attachment-id="102936" data-permalink="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/aoqeyqst1-pru188rzjgs3mpzj7dsqj0j5-dlllbyfznpdfzesnj9giyprbk1rswi69ql-9y0pwcg0aj4ombxkihirpmwkvehknyzo87xiryjuohjxehffw-vesw/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?fit=1476%2C132&amp;ssl=1" data-orig-size="1476,132" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW" data-image-description data-image-caption="&lt;p&gt;The existing x86 code&lt;/p&gt;
" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?fit=300%2C27&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?fit=690%2C62&amp;ssl=1" class="size-large wp-image-102936 jetpack-lazy-image" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?resize=690%2C62&#038;ssl=1" alt width="690" height="62" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?resize=1024%2C92&amp;ssl=1 1024w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?resize=300%2C27&amp;ssl=1 300w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?resize=768%2C69&amp;ssl=1 768w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?resize=1200%2C107&amp;ssl=1 1200w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?w=1476&amp;ssl=1 1476w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?w=1380&amp;ssl=1 1380w" data-lazy-sizes="(max-width: 690px) 100vw, 690px" data-lazy-src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?resize=690%2C62&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" aria-describedby="caption-attachment-102936" data-attachment-id="102936" data-permalink="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/aoqeyqst1-pru188rzjgs3mpzj7dsqj0j5-dlllbyfznpdfzesnj9giyprbk1rswi69ql-9y0pwcg0aj4ombxkihirpmwkvehknyzo87xiryjuohjxehffw-vesw/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?fit=1476%2C132&amp;ssl=1" data-orig-size="1476,132" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW" data-image-description="" data-image-caption="&lt;p&gt;The existing x86 code&lt;/p&gt;
" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?fit=300%2C27&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?fit=690%2C62&amp;ssl=1" loading="lazy" class="size-large wp-image-102936" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?resize=690%2C62&#038;ssl=1" alt="" width="690" height="62" srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?resize=1024%2C92&amp;ssl=1 1024w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?resize=300%2C27&amp;ssl=1 300w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?resize=768%2C69&amp;ssl=1 768w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?resize=1200%2C107&amp;ssl=1 1200w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?w=1476&amp;ssl=1 1476w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/aOqEyQsT1-prU188RZJGS3MPzJ7DSQj0J5-dLLlbyfZnpDfZesnj9gIypRbK1RSwi69Ql-9Y0PWCG0Aj4ombXKihiRPmWKvEhKNyZo87xiRYJUOHjXeHfFw-vesW.png?w=1380&amp;ssl=1 1380w" sizes="(max-width: 690px) 100vw, 690px" data-recalc-dims="1"  /></noscript></a><p id="caption-attachment-102936" class="wp-caption-text">The existing x86 code</p></div>
<div id="attachment_102937" style="width: 700px" class="wp-caption aligncenter"><a href="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?ssl=1"><img aria-describedby="caption-attachment-102937" data-attachment-id="102937" data-permalink="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/ajhsxg1m2tk5tsbdfqbs7k1pwbnrh2llhes342xmtpk6nivz6cgvw2u8sri1mlvcbn8scgifdctc6seshqjcin5c6aoz0ymumuligmq_fnzzxbe0ekifkyf2c8dq/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?fit=1264%2C332&amp;ssl=1" data-orig-size="1264,332" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ" data-image-description data-image-caption="&lt;p&gt;The translated ARM64 code&lt;/p&gt;
" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?fit=300%2C79&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?fit=690%2C181&amp;ssl=1" class="size-large wp-image-102937 jetpack-lazy-image" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?resize=690%2C181&#038;ssl=1" alt width="690" height="181" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?resize=1024%2C269&amp;ssl=1 1024w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?resize=300%2C79&amp;ssl=1 300w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?resize=768%2C202&amp;ssl=1 768w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?resize=1200%2C315&amp;ssl=1 1200w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?w=1264&amp;ssl=1 1264w" data-lazy-sizes="(max-width: 690px) 100vw, 690px" data-lazy-src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?resize=690%2C181&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" aria-describedby="caption-attachment-102937" data-attachment-id="102937" data-permalink="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/ajhsxg1m2tk5tsbdfqbs7k1pwbnrh2llhes342xmtpk6nivz6cgvw2u8sri1mlvcbn8scgifdctc6seshqjcin5c6aoz0ymumuligmq_fnzzxbe0ekifkyf2c8dq/" data-orig-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?fit=1264%2C332&amp;ssl=1" data-orig-size="1264,332" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ" data-image-description="" data-image-caption="&lt;p&gt;The translated ARM64 code&lt;/p&gt;
" data-medium-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?fit=300%2C79&amp;ssl=1" data-large-file="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?fit=690%2C181&amp;ssl=1" loading="lazy" class="size-large wp-image-102937" src="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?resize=690%2C181&#038;ssl=1" alt="" width="690" height="181" srcset="https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?resize=1024%2C269&amp;ssl=1 1024w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?resize=300%2C79&amp;ssl=1 300w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?resize=768%2C202&amp;ssl=1 768w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?resize=1200%2C315&amp;ssl=1 1200w, https://i0.wp.com/blog.trailofbits.com/wp-content/uploads/2022/10/AjhsXG1M2tk5tSBDFQBS7K1pWbNrH2lLHEs342xMTPK6NiVz6cgVW2U8srI1MlVCBN8scGIFdctC6seShQjCIN5c6aOZ0ymumULigmQ_FnZzxBE0EKiFkYF2c8DQ.png?w=1264&amp;ssl=1 1264w" sizes="(max-width: 690px) 100vw, 690px" data-recalc-dims="1"  /></noscript></a><p id="caption-attachment-102937" class="wp-caption-text">The translated ARM64 code</p></div>
<p>Note that ARM64’s fixed instruction size of 4 bytes means that you can’t encode every 32-bit immediate in a single instruction, and ARM64 ALU instructions can encode only a very limited range of immediate values. So some simple eBPF instructions require multiple ARM64 instructions (e.g., <code>emit_load_immediate64</code> may emit more than one instruction to move the immediate into the scratch register), even if they require only a single x86 instruction.</p>
<h3>Some surprises</h3>
<p>The ARM64 ABI has a <a href="https://github.com/ARM-software/abi-aa/blob/60a8eb8c55e999d74dac5e368fc9d7e36e38dda4/aapcs64/aapcs64.rst#6221universal-stack-constraints" target="_blank" rel="noopener">required stack alignment</a> of 16-bytes <em>at the time of any SP-relative access</em>; this alignment is supposed to be enforced by hardware. QEMU does not enforce this alignment by default, but the Apple M1 does.</p>
<p>The subroutines (which are responsible for exception handling, address translation, resolving indirect calls, etc.) each have slightly different conventions for their inputs and outputs, and these conventions are not well documented. Rewriting these subroutines correctly in ARM64 was, by far, the most time-consuming part of this process. I did eventually document many of my <a href="https://github.com/solana-labs/rbpf/pull/359/commits/b82e67a3eedcd5a40aae6d7a1b045dfe4f4fb3d3#diff-5270e866a865009ef299fbbf96f619af3a4000909bb02d5a093ed99296d5573fR634" target="_blank" rel="noopener">assumptions</a> about these subroutines. These subroutines are also responsible for some quite complex logic, including address translation and instruction meter accounting.</p>
<p>When I published the ARM64 port, I made sure it was <a href="https://github.com/solana-labs/rbpf/pull/358/files#diff-7d39efd566d08b201d1e747f11b3909be0d39fd3d4c89cfd28e0b21bab3ec27aR187" target="_blank" rel="noopener">behind a feature-gate</a>, <code>jit-aarch64-not-safe-for-production</code>. This is an intern project aimed to allow developers to use the JIT compiler, and it is not ready for production until it has received a thorough peer review.</p>
<p>My ARM64 port of RBPF is currently available through the <a href="https://github.com/trail-of-forks/rbpf/tree/pr-aarch64" target="_blank" rel="noopener">Trail of Bits fork</a> or <a href="https://github.com/solana-labs/rbpf/pull/358" target="_blank" rel="noopener">this pull request</a>.</p>
<h3>Winapi</h3>
<p>The Windows virtual memory APIs use <code>VirtualAlloc</code> and <code>VirtualProtect</code> in lieu of <code>mmap</code> and <code>mprotect</code>. For our purposes, these are nearly drop-in replacements—I just had to pick the permission and allocation options that correspond most closely to those used in <code>mmap</code> and <code>mprotect</code>.</p>
<h3>Calling convention</h3>
<p>The Windows x64 calling convention designates different registers as caller and callee-save; it also has an additional “shadow space” requirement in which callers are responsible for leaving 32 bytes of space on the stack before the call (after any stack-resident arguments have been pushed).</p>
<p>As with ARM64, Windows support is behind a feature flag, <code>jit-windows-not-safe-for-production</code>.</p>
<h2>A small, unexploitable bug</h2>
<p>My ARM64 port of RBPF did uncover a small, unexploitable uninitialized memory bug that was present even in the existing x86 JIT compiler. <a href="https://github.com/solana-labs/rbpf/pull/358#issuecomment-1193152067" target="_blank" rel="noopener">VTCAKAVSMoACE pointed out</a> some warnings when running my ARM64 branch under the LLVM memory sanitizer (MSAN). I investigated these warnings and found the culprit to be this function:</p>
<pre class="brush: plain; title: ; notranslate" title="">fn emit_set_exception_kind&lt;E: UserDefinedError&gt;(jit: &amp;mut JitCompiler, err: EbpfError&lt;E&gt;) {
    let err = Result::&lt;u64, EbpfError&lt;E&gt;&gt;::Err(err);
    let err_kind = unsafe { *(&amp;err as *const _ as *const u64).offset(1) };
    ...
    emit_ins(jit, X86Instruction::store_immediate(OperandSize::S64, R10, X86IndirectAccess::Offset(8), err_kind as i64));
}</pre>
<p>This function takes an <code>EbpfError</code> value as the second argument, moves it into a <code>Result</code>, and then uses unsafe code to grab bytes 8 through 16 out of the <code>Result</code>. These bytes correspond to the integer discriminant that determines which variant (error type) the <code>EbpfError</code> is. No guarantees are made by the Rust compiler about the size or layout of enums, unless you <a href="https://doc.rust-lang.org/reference/type-layout.html#primitive-representation-of-enums-with-fields" target="_blank" rel="noopener">add a repr attribute to the enum</a> (like <code>#[repr(u64)]</code>).</p>
<p>The Rust compiler had decided that the <code>EbpfError</code> enum discriminant would be only a <code>u8</code>, so the enum that is passed to <code>emit_set_exception_kind</code> actually had 7 bytes of uninitialized stack memory that was being written into the JIT code region. Uninitialized (potentially attacker-controlled) bytes that are written into an executable region is not a bug on its own, but they partially defeat the purpose of the code-reuse mitigations discussed above.</p>
<p>I opened a <a href="https://github.com/solana-labs/rbpf/pull/361" target="_blank" rel="noopener">pull request</a> that adds #[<code>repr(u64)</code>]. Since the JIT compiler makes an additional assumption about enum layouts (i.e., for <code>Result</code> in the Rust standard library), I also added tests that should detect whether the compiler ever changes the location or size of the enum discriminant on certain types.</p>
<h2>Conclusion</h2>
<p>Given how important the RBPF JIT compiler is to the Solana blockchain, we felt that it was important for the widest range of developers to use it on whatever machine they are using for development. Now, it’s possible for developers using either M1 and Windows machines to also use the JIT compiler during testing. While the work still needs a peer review, it can be found in two pull requests on GitHub. Feel free to try it out!</p>
<p>Thanks to Anders Helsing for the fantastic guidance as I explored the internals of RBPF, and learned the finer points of both the ARM64 and Windows x64 ABI.</p>
<p>This work shows how Trail of Bits is rooted in solving Solana’s security challenges, building upon the deep Solana expertise we’ve used to build tools we have already released to the public. Not only do we aim to make Solana as secure as possible, we want to make the tools engineers use with Solana equally as secure. Our ultimate goal with these efforts is to raise the security level for all of the Solana projects that will be built in the future.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-102908" class="share-twitter sd-button share-icon" href="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/?share=twitter" target="_blank" title="Click to share on Twitter" ><span>Twitter</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-102908" class="share-linkedin sd-button share-icon" href="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/?share=linkedin" target="_blank" title="Click to share on LinkedIn" ><span>LinkedIn</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/?share=reddit" target="_blank" title="Click to share on Reddit" ><span>Reddit</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon" href="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/?share=telegram" target="_blank" title="Click to share on Telegram" ><span>Telegram</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-102908" class="share-facebook sd-button share-icon" href="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/?share=facebook" target="_blank" title="Click to share on Facebook" ><span>Facebook</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/?share=pocket" target="_blank" title="Click to share on Pocket" ><span>Pocket</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="mailto:?subject=%5BShared%20Post%5D%20Porting%20the%20Solana%20eBPF%20JIT%20compiler%20to%20ARM64&body=https%3A%2F%2Fblog.trailofbits.com%2F2022%2F10%2F12%2Fsolana-jit-compiler-ebpf-arm64%2F&share=email" target="_blank" title="Click to email a link to a friend" data-email-share-error-title="Do you have email set up?" data-email-share-error-text="If you&#039;re having problems sharing via email, you might not have email set up for your browser. You may need to create a new email yourself." data-email-share-nonce="1389a5358c" data-email-share-track-url="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/?share=email"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/#print" target="_blank" title="Click to print" ><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-3681601-102908-634840ad7c08c' data-src='https://widgets.wp.com/likes/#blog_id=3681601&amp;post_id=102908&amp;origin=blog.trailofbits.com&amp;obj_id=3681601-102908-634840ad7c08c' data-name='like-post-frame-3681601-102908-634840ad7c08c' data-title='Like or Reblog'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>			</div><!-- .entry-content -->

	<footer class="entry-footer">
		<p class="entry-byline">By Trail of Bits</p>
		<p class="cat-links">Posted in <a href="https://blog.trailofbits.com/category/blockchain/" rel="category tag">Blockchain</a>, <a href="https://blog.trailofbits.com/category/crytic/" rel="category tag">Crytic</a>, <a href="https://blog.trailofbits.com/category/engineering-practice/" rel="category tag">Engineering Practice</a>, <a href="https://blog.trailofbits.com/category/internship-projects/" rel="category tag">Internship Projects</a>, <a href="https://blog.trailofbits.com/category/uncategorized/" rel="category tag">Uncategorized</a></p>
			</footer>
</article><!-- #post-102908 -->
						<nav role="navigation" id="nav-below" class="site-navigation post-navigation">
			<h1 class="assistive-text">Post navigation</h1>

		
			<div class="nav-previous"><a href="https://blog.trailofbits.com/2022/10/05/trail-of-bits-internship-blockchain-tealer/" rel="prev"><span class="meta-nav">&larr;</span> Working on blockchains as a Trail of Bits intern</a></div>			
		
		</nav><!-- #nav-below -->
		
					<div id="comments" class="comments-area">
	
	
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/10/12/solana-jit-compiler-ebpf-arm64/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=3681601&#038;postid=102908&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;jetpack_comments_nonce=7f2c6b3eac&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=11.5-a.3&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=3ab4ae69189240d8d76fb0889478d75c5540aa60#parent=https%3A%2F%2Fblog.trailofbits.com%2F2022%2F10%2F12%2Fsolana-jit-compiler-ebpf-arm64%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments .comments-area -->

			
			</div><!-- #content -->
		</div><!-- #primary .site-content -->

		<div id="secondary" class="widget-area" role="complementary">
						<aside id="search-4" class="widget widget_search">	<form method="get" id="searchform" action="https://blog.trailofbits.com/" role="search">
		<label for="s" class="assistive-text">Search</label>
		<input type="search" class="field" name="s" id="s" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
	</form>
</aside><aside id="text-112416548" class="widget widget_text"><h1 class="widget-title">About Us</h1>			<div class="textwidget"><p>Since 2012, Trail of Bits has helped secure some of the world’s most targeted organizations and products. We combine high-­end security research with a real­ world attacker mentality to reduce risk and fortify code.</p>
<p>Read more at <a href="https://www.trailofbits.com">www.trailofbits.com</a></p>
</div>
		</aside><aside id="rss_links-4" class="widget widget_rss_links"><h1 class="widget-title">Subscribe via RSS</h1><p><a target="_self" href="https://blog.trailofbits.com/feed/" title="Subscribe to posts"><img src="https://blog.trailofbits.com/wp-content/plugins/jetpack/images/rss/red-small.png" alt="RSS feed" />&nbsp;RSS - Posts</a></p>
</aside>
		<aside id="recent-posts-5" class="widget widget_recent_entries">
		<h1 class="widget-title">Recent Posts</h1>
		<ul>
											<li>
					<a href="https://blog.trailofbits.com/2022/10/12/solana-jit-compiler-ebpf-arm64/" aria-current="page">Porting the Solana eBPF JIT compiler to ARM64</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/10/05/trail-of-bits-internship-blockchain-tealer/">Working on blockchains as a Trail of Bits intern</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/10/03/semgrep-maching-learning-static-analysis/">Secure your machine learning with Semgrep</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/09/15/it-pays-to-be-circomspect/">It pays to be Circomspect</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/08/25/magnifier-an-experiment-with-interactive-decompilation/">Magnifier: An Experiment with Interactive Decompilation</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/08/17/using-mutants-to-improve-slither/">Using mutants to improve Slither</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/08/12/the-road-to-the-apprenticeship/">The road to the apprenticeship</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/07/28/shedding-smart-contract-storage-with-slither/">Shedding smart contract storage with Slither</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/07/01/libmagic-the-blathering/">libmagic: The Blathering</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/06/30/a-typical-day-as-a-trail-of-bits-engineer-consultant/">A Typical Day as a Trail of Bits Engineer-Consultant</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/06/28/the-trail-of-bits-hiring-process/">The Trail of Bits Hiring Process</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/06/24/managing-risk-in-blockchain-deployments/">Managing risk in blockchain deployments</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/06/21/are-blockchains-decentralized/">Are blockchains decentralized?</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/06/20/announcing-the-new-trail-of-bits-podcast/">Announcing the new Trail of Bits podcast</a>
									</li>
											<li>
					<a href="https://blog.trailofbits.com/2022/06/09/themes-from-pycon-us-2022/">Themes from PyCon US 2022</a>
									</li>
					</ul>

		</aside><aside id="text-112416546" class="widget widget_text"><h1 class="widget-title">Yearly Archive</h1>			<div class="textwidget"><ul>
<li><a href="https://blog.trailofbits.com/2020">2020</a></li>
<li><a href="https://blog.trailofbits.com/2019">2019</a></li>
<li><a href="https://blog.trailofbits.com/2018">2018</a></li>
<li><a href="https://blog.trailofbits.com/2017">2017</a></li>
<li><a href="https://blog.trailofbits.com/2016">2016</a></li>
<li><a href="https://blog.trailofbits.com/2015">2015</a></li>
<li><a href="https://blog.trailofbits.com/2014">2014</a></li>
<li><a href="https://blog.trailofbits.com/2013">2013</a></li>
<li><a href="https://blog.trailofbits.com/2012">2012</a></li>
</ul></div>
		</aside><aside id="categories-4" class="widget widget_categories"><h1 class="widget-title">Categories</h1>
			<ul>
					<li class="cat-item cat-item-291"><a href="https://blog.trailofbits.com/category/apple/">Apple</a> (13)
</li>
	<li class="cat-item cat-item-141319"><a href="https://blog.trailofbits.com/category/attacks/">Attacks</a> (9)
</li>
	<li class="cat-item cat-item-685590231"><a href="https://blog.trailofbits.com/category/audits/">Audits</a> (1)
</li>
	<li class="cat-item cat-item-44620"><a href="https://blog.trailofbits.com/category/authentication/">Authentication</a> (5)
</li>
	<li class="cat-item cat-item-502354744"><a href="https://blog.trailofbits.com/category/binary-ninja/">Binary Ninja</a> (12)
</li>
	<li class="cat-item cat-item-64575263"><a href="https://blog.trailofbits.com/category/blockchain/">Blockchain</a> (50)
</li>
	<li class="cat-item cat-item-1364812"><a href="https://blog.trailofbits.com/category/capture-the-flag/">Capture the Flag</a> (11)
</li>
	<li class="cat-item cat-item-685590242"><a href="https://blog.trailofbits.com/category/careers/">Careers</a> (1)
</li>
	<li class="cat-item cat-item-685590226"><a href="https://blog.trailofbits.com/category/codeql/">CodeQL</a> (2)
</li>
	<li class="cat-item cat-item-100030"><a href="https://blog.trailofbits.com/category/compilers/">Compilers</a> (23)
</li>
	<li class="cat-item cat-item-9204"><a href="https://blog.trailofbits.com/category/conferences/">Conferences</a> (28)
</li>
	<li class="cat-item cat-item-182564"><a href="https://blog.trailofbits.com/category/containers/">Containers</a> (2)
</li>
	<li class="cat-item cat-item-25818"><a href="https://blog.trailofbits.com/category/cryptography/">Cryptography</a> (39)
</li>
	<li class="cat-item cat-item-28634997"><a href="https://blog.trailofbits.com/category/crytic/">Crytic</a> (3)
</li>
	<li class="cat-item cat-item-199448218"><a href="https://blog.trailofbits.com/category/cyber-grand-challenge/">Cyber Grand Challenge</a> (7)
</li>
	<li class="cat-item cat-item-55871"><a href="https://blog.trailofbits.com/category/darpa/">DARPA</a> (21)
</li>
	<li class="cat-item cat-item-4181544"><a href="https://blog.trailofbits.com/category/dynamic-analysis/">Dynamic Analysis</a> (12)
</li>
	<li class="cat-item cat-item-1342"><a href="https://blog.trailofbits.com/category/education/">Education</a> (14)
</li>
	<li class="cat-item cat-item-551269408"><a href="https://blog.trailofbits.com/category/empire-hacking/">Empire Hacking</a> (7)
</li>
	<li class="cat-item cat-item-1360277"><a href="https://blog.trailofbits.com/category/engineering-practice/">Engineering Practice</a> (12)
</li>
	<li class="cat-item cat-item-924"><a href="https://blog.trailofbits.com/category/events/">Events</a> (5)
</li>
	<li class="cat-item cat-item-14563"><a href="https://blog.trailofbits.com/category/exploits/">Exploits</a> (27)
</li>
	<li class="cat-item cat-item-1643774"><a href="https://blog.trailofbits.com/category/fuzzing/">Fuzzing</a> (29)
</li>
	<li class="cat-item cat-item-2812"><a href="https://blog.trailofbits.com/category/go/">Go</a> (4)
</li>
	<li class="cat-item cat-item-320"><a href="https://blog.trailofbits.com/category/guides/">Guides</a> (9)
</li>
	<li class="cat-item cat-item-25357667"><a href="https://blog.trailofbits.com/category/internship-projects/">Internship Projects</a> (29)
</li>
	<li class="cat-item cat-item-96379492"><a href="https://blog.trailofbits.com/category/iverify/">iVerify</a> (4)
</li>
	<li class="cat-item cat-item-46713213"><a href="https://blog.trailofbits.com/category/kubernetes/">Kubernetes</a> (2)
</li>
	<li class="cat-item cat-item-610"><a href="https://blog.trailofbits.com/category/linux/">Linux</a> (1)
</li>
	<li class="cat-item cat-item-685590236"><a href="https://blog.trailofbits.com/category/machine-learning/">Machine Learning</a> (6)
</li>
	<li class="cat-item cat-item-15593"><a href="https://blog.trailofbits.com/category/malware/">Malware</a> (7)
</li>
	<li class="cat-item cat-item-1056516"><a href="https://blog.trailofbits.com/category/manticore/">Manticore</a> (15)
</li>
	<li class="cat-item cat-item-245013018"><a href="https://blog.trailofbits.com/category/mcsema/">McSema</a> (11)
</li>
	<li class="cat-item cat-item-171"><a href="https://blog.trailofbits.com/category/meta/">Meta</a> (12)
</li>
	<li class="cat-item cat-item-6701995"><a href="https://blog.trailofbits.com/category/mitigations/">Mitigations</a> (9)
</li>
	<li class="cat-item cat-item-293462444"><a href="https://blog.trailofbits.com/category/osquery/">osquery</a> (21)
</li>
	<li class="cat-item cat-item-208532"><a href="https://blog.trailofbits.com/category/paper-review/">Paper Review</a> (11)
</li>
	<li class="cat-item cat-item-685590244"><a href="https://blog.trailofbits.com/category/people/">People</a> (1)
</li>
	<li class="cat-item cat-item-685590238"><a href="https://blog.trailofbits.com/category/podcast/">Podcast</a> (1)
</li>
	<li class="cat-item cat-item-6672"><a href="https://blog.trailofbits.com/category/press-release/">Press Release</a> (25)
</li>
	<li class="cat-item cat-item-3279"><a href="https://blog.trailofbits.com/category/privacy/">Privacy</a> (9)
</li>
	<li class="cat-item cat-item-1589"><a href="https://blog.trailofbits.com/category/products/">Products</a> (5)
</li>
	<li class="cat-item cat-item-5030448"><a href="https://blog.trailofbits.com/category/program-analysis/">Program Analysis</a> (16)
</li>
	<li class="cat-item cat-item-685590239"><a href="https://blog.trailofbits.com/category/recruitment/">Recruitment</a> (1)
</li>
	<li class="cat-item cat-item-685590241"><a href="https://blog.trailofbits.com/category/remote-work/">Remote Work</a> (1)
</li>
	<li class="cat-item cat-item-113884"><a href="https://blog.trailofbits.com/category/research-practice/">Research Practice</a> (17)
</li>
	<li class="cat-item cat-item-299073"><a href="https://blog.trailofbits.com/category/reversing/">Reversing</a> (14)
</li>
	<li class="cat-item cat-item-185574"><a href="https://blog.trailofbits.com/category/rust/">Rust</a> (4)
</li>
	<li class="cat-item cat-item-685590219"><a href="https://blog.trailofbits.com/category/safedocs/">SafeDocs</a> (1)
</li>
	<li class="cat-item cat-item-685590218"><a href="https://blog.trailofbits.com/category/sinter/">Sinter</a> (1)
</li>
	<li class="cat-item cat-item-685590237"><a href="https://blog.trailofbits.com/category/slither/">Slither</a> (2)
</li>
	<li class="cat-item cat-item-401665"><a href="https://blog.trailofbits.com/category/sponsorships/">Sponsorships</a> (12)
</li>
	<li class="cat-item cat-item-538062"><a href="https://blog.trailofbits.com/category/static-analysis/">Static Analysis</a> (28)
</li>
	<li class="cat-item cat-item-19674948"><a href="https://blog.trailofbits.com/category/symbolic-execution/">Symbolic Execution</a> (17)
</li>
	<li class="cat-item cat-item-943"><a href="https://blog.trailofbits.com/category/training/">Training</a> (1)
</li>
	<li class="cat-item cat-item-1"><a href="https://blog.trailofbits.com/category/uncategorized/">Uncategorized</a> (20)
</li>
	<li class="cat-item cat-item-685590240"><a href="https://blog.trailofbits.com/category/working-at-trail-of-bits/">Working at Trail of Bits</a> (2)
</li>
	<li class="cat-item cat-item-29911"><a href="https://blog.trailofbits.com/category/year-in-review/">Year in Review</a> (4)
</li>
	<li class="cat-item cat-item-685590235"><a href="https://blog.trailofbits.com/category/zero-knowledge/">Zero Knowledge</a> (8)
</li>
			</ul>

			</aside><aside id="twitter_timeline-3" class="widget widget_twitter_timeline"><a class="twitter-timeline" data-height="400" data-theme="light" data-border-color="#e8e8e8" data-tweet-limit="8" data-lang="EN" data-partner="jetpack" data-chrome="nofooter transparent" href="https://twitter.com/trailofbits" href="https://twitter.com/trailofbits">My Tweets</a></aside>		</div><!-- #secondary .widget-area -->

	</div><!-- #main -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
						<a></a>
			
					</div><!-- .site-info -->
	</footer><!-- .site-footer .site-footer -->
</div><!-- #page .hfeed .site -->

<!--  -->
<script defer id="bilmur" data-provider="wordpress.com" data-service="atomic"  src="https://s0.wp.com/wp-content/js/bilmur.min.js?m=202241"></script>
		<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.trailofbits.com\/2022\/10\/12\/solana-jit-compiler-ebpf-arm64\/":102908};
	</script>
				<script type='text/javascript'  src='https://blog.trailofbits.com/_static/??-eJwrL9BNzs8rSc0r0S/IKU3PzCvWL67MK0msyMhMz8gB4pLUIkwRY/3i5KLMghKg4gzn/KJUvaxinXKKTXIqKi3OCMhJzMwDmmefa2toZmpkbmxsZmAMAIcdP60='></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://blog.trailofbits.com/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		document.head.appendChild( corecss );
		var themecssurl = "https://blog.trailofbits.com/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeDefault.css?ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		document.head.appendChild( themecss );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ expand source';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Can\'t find brush for: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Brush wasn\'t configured for html-script option: ';
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.all();

	// Infinite scroll support
	if ( typeof( jQuery ) !== 'undefined' ) {
		jQuery( function( $ ) {
			$( document.body ).on( 'post-load', function() {
				SyntaxHighlighter.highlight();
			} );
		} );
	}
</script>
<link rel='stylesheet' id='all-css-d77622eb680dd7b9b8dd63b8c4d730db' href='https://blog.trailofbits.com/_static/??-eJyVjFsKgCAQAC+UbWYEfURnMV3C8oXr4vUjqAP0O8NMy8KkWDFWyJ4PFwlOrFmbC0Ky7JHA6JKY0AM1l7GInaP12Buirv2oXyE+8Ay2sMpZyWFcpJpuzec0Gg==' type='text/css' media='all' />
<script id='jetpack-lazy-images-js-extra'>
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
</script>
<script id='jetpack-carousel-js-extra'>
var jetpackSwiperLibraryPath = {"url":"https:\/\/blog.trailofbits.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.trailofbits.com\/wp-admin\/admin-ajax.php","nonce":"c1d9f6237a","display_exif":"0","display_comments":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/blog.trailofbits.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.trailofbits.com%2F2022%2F10%2F12%2Fsolana-jit-compiler-ebpf-arm64%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
</script>
<script type='text/javascript'  src='https://blog.trailofbits.com/_static/??-eJytUNFOwzAM/CGyCA2VvSA+ZUoTs7p1nJA4q7qvJxvZhgBNQ+LJyvnucuc5KhtYgEVHKjvkrEeQaOykt8hW9wXJ6TgECdzGyiOvxvww/5Ta0FOwU9YOs+jxCijD6I1g+K6UATxkDXtIizPLUZO9IVIeuDRuzUHFVdbJ0NeNqASRlhtJfikhM4pAUoIeCBnuULe53QO7kLQpEmoLQXveKDKHRdVqO2ilsTqlDPbYVYU+Q6rV/v+bL8D9FyCcqv69QIHBsKMa7E8XtCaFkoEusc7ADRszYfYgnzbtod7SieWq5tW/PHbd0/p5s1l3HyfD+dw='></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script src='https://blog.trailofbits.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=11.5-a.3' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-telegram' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-telegram' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-pocket' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-pocket' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202241#ver=202241' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=3681601&postid=102908&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&jetpack_comments_nonce=7f2c6b3eac&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.5-a.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=3ab4ae69189240d8d76fb0889478d75c5540aa60#parent=https%3A%2F%2Fblog.trailofbits.com%2F2022%2F10%2F12%2Fsolana-jit-compiler-ebpf-arm64%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=3681601&postid=102908&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&jetpack_comments_nonce=7f2c6b3eac&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.5-a.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=3ab4ae69189240d8d76fb0889478d75c5540aa60#parent=https%3A%2F%2Fblog.trailofbits.com%2F2022%2F10%2F12%2Fsolana-jit-compiler-ebpf-arm64%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>

			<script src='https://stats.wp.com/e-202241.js' defer></script>
	<script>
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'3681601',post:'102908',tz:'-4',srv:'blog.trailofbits.com',hp:'atomic',ac:'2',amp:'0',j:'1:11.5-a.3'} ]);
		_stq.push([ 'clickTrackerInit', '3681601', '102908' ]);
	</script>
</body>
</html>
<!--
	generated 251 seconds ago
	generated in 0.195 seconds
	served from batcache in 0.002 seconds
	expires in 49 seconds
-->
